Ok I found out how to fix this problem. My computer needed to have a static ip from which I was told by the installation of my router's manual it said to obtain. So anyways i can connect to my irc server.

I went onto the dlink website. Looked at the tech support for port forwarding. inputed my ip + port. Went to network connections properties on the ip one. made my ip as static filled in the gateway as the router. got the 2 main DNS servers from my ISP. Saved all of that rebooted my system. loaded mIRC. It took 10 seconds to connect to the server. everything was working.

So if anyone Has a DSL-504g router copy what i did and see if this works.

1. go to http://www.dlink.com.au/tech/
2. chose your router/modem
3. click on Open ports.
4. how to open ports.
5. Do everything they say. Add your isp Dns servers in the network card configure.
6. Save the settings.
7. Reboot your own system.
8. Login to your mirc network.