Ok ... let's get something else out. Here is what I tried:

Using my link straight from my Road Runner connection. <-- Still didn't work.

I tried using Trillian's IRC ... <-- Worked much better than mIRC but still disconnected.

I tried upgrading my drivers (again) for my network card. <-- Still didn't work.

I am pinning it to something is wrong with Microsoft on this one. Let's face it... it is when we try with a Win2k or WinXP right? Fair enough, now if you trace back the original 10053 error you will be brought to a winsock problem. Yes that is used since Win 95, and even later editions of Win3.1. That however has not changed in MANY years. Therefore we can eliminate mIRC as the only one doing this, routers are fine. Now can anyone speak from a coding point of view on this as to what exactly does the winsock mechanism do and can it be botched? If so how? Let's try to get an active (cure all) resolve to this. Continue to place a bandaid on this .... but let's try to cut off the source. That is all I really am going to say.