Ok people, I dont mean to kick up dust, and certainly dont want to turn this into a (excuse my realism) pissing contest (which I'd win), but replies to my post do nothing but create more threads to an already crowded topic. I have been dealing with this issue months before the first thread about this topic was posted, and over a year later I have still not found an iron clad way to get around this problem. I'm glad that people in the mIRC community are taking time to try to help people with this problem(ie: Mentality), but I'm afraid and feel confident that if you have this problem, as mentioned in my previous post, then your just out of luck :P

I hate saying that as much as It may upset people dealing with this repetitave problem, but I feel I've done everything I could, including calling Dell(which said 10053 was a network settings error = no help) to find a solution to this problem,,, to no avail.

To DaveC: I realize(wether you do or not) that EVERY OS(including openBSD, which has had one exploit in 8 years), and most programs including mIRC(which has had a few critical security holes) are succeptible to being exploited in one way or another. As a Physical Security Specialist I accept and embrace this as part of life as well as part of my job to identify. I'm not as arrogant as I am "upfront", but I will tell you/the world and Bill Gates himself for that matter that Window's is one of the most unsecure operating systems, and until Bill re-writes Windows from ground up (which will never happen) and actually sacrafices some usabilty/eyecandy for security, then I advise against using it. Far beyond 3/4 of Linux's exploits come from MISCONFIGURED SERVERS and/or bad cgi scripting which make up for more than %50 of exploits on the web. But just because some cgi script is exploitable does not mean it's Linux's fault. As a perl/cgi coder, I admit to have written exploitable code as well as written code to test these holes.
Bottom line,, Windows is a MASSIVE, inpenetrable, pretty safe,,,,,,,,,, that has a lil hole in the back of it that any one can reach in and grab what they want, and now that windows source code has been distributed(cough,Cough),, expect large numbers of exploits to arise. And please remember Linux is/has been and will always be open source which was around before the first stable distro of Windows 3.1(Yes, it was out before Windows). Linux was written by hackers, and the source is, and has been thoroughly screened by them for over 15 years now.
Unfortunately I require my computers to be hot rods, and when they stall or govern out at 60 mph,, they are well on their way to the junkyard as far as I'm concerned, and/or on their way to ebay to someone who wants to deal with it.
Please leave security to me.

And PS. mIRC DOES work on Linux :P
Although you have to do a semi-007, check out http://www.winehq.com and read http://www.mirc.co.uk/help/linux.html

Ok, back on the subject :P

If you've read this far, I either annoyed you by my last post or your having these 10053 problems.

Either of which, I'd like to take a pro-active role on this issue and ask anyone that has this problem to post some info other than the fact that you got an 10053 error, which we know, and some system spec's.

First off I agree that if it repetitvely happens when you initially boot mIRC and will NOT let you connect to ANY IRC server, IT IS A FIREWALL/NETWORK SETTING ERROR which is not isolated to the mIRC client only, but to all IRC client's. This "brand" of 10053 error is correctable by you or your network admin. If your on a college campus,,, forget it. I assure you, your net admin will do nothing but tell you he does'nt allow IRC connections as I dont on my workplace environments. Either way fiddle around with your firewall settings and try again and/or try a different client to make sure your allowed to connect to irc ports. If you try another client and it still will not connect, I can almost guarantee you that your firewall/net admin has blocked your IRC access. As a realist, I admit that there are ways around this, and only because there are legit/legal services that offer this kind of help, I will advise you to google BNC.

Now if you have the same problem as I do, I'll recap on my symptom's:

mIRC works fine with no error until I run memory intensive; Multi--threading; tcp/ip protocal utilizing program's such as x-scan/nmap/accessdiver/ares/etc.
When I do run them, the programs seem to run fine, but yield no results. and when I get the 10053 error on mIRC, all of my internet services hang such as my web browser/ftp/p2p etc. for about 5 minutes, representing that of a DDoS and or DoS attack(Im sure it's not btw).

So if you have problems identical to mine, please post your computer make; model; processor; any service packs(IMPORTANT! make sure to check for service pack 2), and if you use any other memory consuming/multi-threading tcp/ip utilizing programs, such as those I have listed.

I request this so that we may be able to isolate this problem to certain systems/service packs etc.

I hope that people will follow thru with this as I am confident this is(as of this time) the only thing we can do about it(except switch to Linux or course :P).

If any one has any other not idea's but solution's please post them, I'd love to hear them.

Ps. I assure you any timer script will not work for this. This is a local problem not an IRC server issue. The only thing that an IRC server wants to see(under most cases) is a PONG to their PING. And as long as your client replies you should have no problem staying connected.