I have similar problems. When I download through mirc, my download speed will rapidly drop. Eventually, it will give me this 10053 error, software caused connection abort. And the next moment, my internet is being cut off till I reboot my com.
As stated in the #1 post about the different suggestions. I have done a series of test on the different suggestions.

disable winxp's firewall:
-I've disable it from the day I installed my windows. I still encounter the mirc error. It's not the cause of the error.

dont use port 6667 to connect to a network. Most networks have a range of ports, usually within 6660-6669,7000-7001 and you can specify a port with /server some.server.here:7000:
-I've tried different ports like 6697,etc. The port isn't the cause of the problem.

dont use "speed patches" that supposedly increase your download speed. (note some of them effect your registry, use speed patch as your search term)
-I've never used speed patch from day 1. It's DEFINITELY not the cause of the problem.

update your router drivers/firmware. (some have said they needed to use something other than the ones supplied by the manufacturer):
-My hardware are all updated. I even tested it with my laptop. My laptop can download without any problems. This is not a cause as well.

connect to the server's ip instead of domain (ie, /server 123.456.789.123 instead of /server some.domain.here):
-I tried it, it's still the same result. Not a cause either.

limit how many networks or other apps you are running:
-I'm running mirc only, and yet I still get that error. It's not a caused by other networks or apps.

some have the prob not while dcc sending, but when idle for long periods of time. try creating a channel and using a timer to make a post every so often.
-Definitely not a cause for mine. I never idle in mirc, always chatting,etc.

uninstall MSN IM:
-I thought this was the most ridiculous suggestion. MSN IM has not caused to this error. I tested my laptop with it, there's no error. Please remove this suggestion.

check for patches for everything from windows to the equipment you have.:
-My windows is updated to the max. As for this cause, I can't test it out. But I tested my mirc on another com using vista os. It works fine. I'm not sure if the cause is due to microsoft patch for windows xp. If it is, many will have this mirc error too.

Changing NIC card:
-I'm getting one new nic card. When I test this hardware. with my router/modem, I will tell you guys the result.

Definitely not for me either. I tested my laptop with the same ISP, connection,etc. Not a cause for this error.

Sorry if I'm rude. But the fact is the suggestions doesn't work. Many others like me are stranded helplessly for months, for years. I done these tests to at least inform others of redundant solutions. I will post again when I do the NIC card test. Thanks

Last edited by syaoran87; 13/04/08 04:54 AM.