I have had the same troubles for quite some time. Typically aborting every few minutes. This problem wasn't just with MIRC, but also with my online game, Gemstone IV. After tons of research and web surfing I found something that worked for me. So, to add to your list of resolutions...

Alternately, you may follow these steps to rebuild your Winsock manually:
1) Go to Control Panel | Internet Options | Connections | LAN Settings and clear all of the boxes.
2) Re-create the Winsock2 registry entries:
a. Un-install ICS (if installed).
b. Un-install Dial-Up Networking. Do NOT reboot.
c. Delete registry key HLM\System\CurrentControlSet\Services\Winsock2
d. Re-install Dial-Up Networking. Reboot.
e. Re-install ICS (if desired).

If you are running Windows XP with Service Pack 2, it is recommended you repair your Winsock using the following instructions:

1) click Start, click Run and type CMD and click OK.
2) At the command prompt type: netsh winsock reset catalog (and press Enter)
3) At the command prompt type: Exit (and press Enter)

Also, check to see if your Winsock is broken or corrupted using any of these utilities:


http://www.bu.edu/pcsc/internetaccess/winsock2fix.html (for Win98, 98se & ME)

http://digital-solutions.co.uk/lavasoft/whndnfix.zip (Win 95, 98, 98se & ME, this will open up in WinZip.)

http://www.hometownohio.com/faq/files/WinsockXPFix.exe (for Win XP, this is an executable file.)

http://www.tacktech.com/display.cfm?ttid=257 (for Windows 98/Me/NT/2000 or XP.)

I'm also going to change my NIC card, but since I ran the utility above for XP and reset the winsock, I haven't seen this error at all.

Good luck with this headache if you have it!