Yet another unable to DCC Send post to add to the bunch =( I can't find a resolution to help me out of all these posts.

I can DCC Receive, DCC Chat, but cannot DCC Send. I am using the following setup:

mIRC 6.16 Registered Version
DSL Connection (Earthlink)
Additional Scripts: OmenServ version 2.52

Windows XP Home SP1 (Windows Firewall disabled)
-- Windows Firewall not enabled on LAN connection
-- Using ZoneAlarm, gave mIRC Access/Server permissions and enabled advanced program control to use other programs

Network Anywhere NR041 Router
-- Setup as a DMZ
-- Able to host internet multiplayer games
-- haven't tried bypassing router (cat5 cable too short! frown)

mIRC Options (detects right external IP)

Connect > Options:
Default Port 6667
DCC Checked in Advanced; Range is 1024-7895

Connect > Local Info:
Local Host, IP Address - correct
Local Host checked, IP Address Checked
Lookup Method Server

DCC > Server:
DCC Enabled
Listens on Port 59
Send, Chat, FServe checked
Perform DNS lookup unchecked

Please respond, can give IM or email information on request. Additional information can be provided as well. This is bugging the &@*@ out of me. confused I've tried using a backup version of mIRC from my D:\ partition without script loaded, no dice. Haven't bypassed router yet, but I have it setup as DMZ, so figuring it's either a stupid mIRC setting or DSL issue. Any help would be greatly appreciated.