here what mungkee do

he have problem 2

open mIRC
DCC options
DCC ports: 1024

go to router settings
forward TCP 1024
be sure enabled
DCC Server settings
Check enable DCC Server

also in Router settings

forward UDP 113
be sure enabled

Mungkee Happy : )

prob already in here
but I think silly to have 3000+ ports open
why have a firewall or router???