Btw, I just had success with the dcc send problem and thought I'd share it.

I have server mode selected, local host checked, all the necessary ports open, etc etc, I tried this for kicks:

Connect > Options > Advanced
Checked bind sockets to ip and then put in my -internal- ip address (find by opening up a command prompt (start > run > "cmd"), typing in ipconfig, and then writing down the ip address it gives you. Usually or 10.x.x.x)

Anyway this worked for me. Good luck smile