"2. While disconnected, in File>Options>Connect>Local info, under on connect always get, clear both the local host and the
greyed out ip address boxes."

I use DSL at home, and found that if I clear the boxes, as stated above, and I choose "On connect, always get" Local Host and "Look Up Method" as Server, it does allow me to DCC send. I have tried other combinations of those settings, without any luck.