although I know no one has posted in this thread for several months, I would still like some help on my problem.
I shall try to give you the information you need in order to help me. The error that I get is

(16:17:36) * Connecting to irc.infiltrate.nl (6667)
(16:17:58) * Unable to connect to server (Connection timed out)

Obviously, I want to connect to irc.infiltrate.nl.
I have tried other servers (quakenet and such) and I get the same message. I have tried connecting to the ip-adresses as well, and that did not work. I don't have a firewall and my virusscan isn't on. I have talked to other people that are usually on the server I go to, and they tell me they don't have any problems connecting. When I try run>cmd and then ping infiltrate.nl, I get 'Time-out at *something*' (it's in Dutch, I don't know the English term for it). I also get this when pinging google.com. I can surf the internet and MSN works just fine, even downloading is not a problem. I have no idea how to get to my router's settings (Realtek RTL8139 Family PCI Fast Ethernet NIC #) (don't know if that's relevant). The problem started yesterday. I had been taking my computer apart because it wasn't working anymore. Then, when it all worked again, so did mIRC. Then I noticed my sound wasn't working, so I took the soundcard out and put it back in (this while my computer was turned off). Then, something happened to the storage device on which I had mIRC installed. I restarted my computer and it worked fine again. Except mIRC. Now I don't know if that has anything to do with it, but I'd rather tell you too much than too little.
I would like some help on this!