i just got it working....

heres what i did, in full, because i dont know if any of this actually helped....

i set the ident server port to 1602
dcc server port to 1601 (and left it disabled)

then i went to : connect->options->advanced, and set this

made sure DCC was ticked (it was)

set DCC port box #1 to 1500
dcc port box #2 to 1510
ticked randomize ports
ticked bind sockets to ip, and put my LAN ip in there (
joined MIRC with 2 clients, joined a seperate channel and verified i could see each one typing

then i went into my router options, and forwarded all the ports to and made my ip static (so my brothers comp doesnt use it and steal my port rule)

joined a channel, requested a file download, and it worked right away.

i have only tested this ONCE, im going to try it again now, if it works i will re-post.....lets pray

P.S i dont know how to use newsgroups smile...

EDIT : just tried it on 2 more servers, it worked for me first time on both new servers...

also, to add to this, BT tech support sucks, i phoned them 5-8 times in 2 days, and none of them had any idea, seems if they dont release the program, they assume its my fault, on another side note : i have not changed anything in my router for 3-4 months, and this came out of nowhere, on 3 seperate routers, on all 3 of my comps, so im really doubting it was my setup that was the problem,

maybe it was nothing i changed which has got it working, maybe its the 15 messages i have sent them in 2 days, and the 8 phone
calls...lets hope so.

Oh, and not sure if this is any help but i tested this on my DLINK DSL504T because there "home hub" only supports 3 comps at max (thats one with usb)

any questions, my msn is bignoob@gmail.com

Last edited by Monkeh; 30/11/06 01:31 PM.