As it says, the server isn't receiving an identd response, so that specific network requires you to use /quote to avoid spam bots. Make sure that identd is enabled in mIRC and also make sure that port 113 is not blocked in any firewall or router that you're using. This is explained in the first post of this thread.

Invision Support
#Invision on