mIRC Homepage

enable identd

Posted By: ParaBrat

enable identd - 07/12/02 07:44 PM

Due to abuse, if you are on many isps, on DALnet and some other networks you must have identd enabled. At http://kline.dal.net/exploits/ident.htm you will see the Ident FAQ on this, and to the left you will find links, click on the one that says Windows Identd for step by step how to enable identd in mIRC and links to standalone identd servers which may solve your problem. (even tho this is on DALnet's website, you can still find helpful info regardless of the network you are on)

Be sure you are not blocking port 113 with firewall (including the one with WinXP, see http://www.mirc.org/xpdcc/default.htm (and note that in v6.14 dcc ports were moved to connect/options, click the advanced button) for help with that) or router. You can find the same info here and here.
Windows XP Service Pack 2 users will find a new Windows Firewall with a slightly new interface. Please see this page for help or this guide. Do note, if you are only going to open port 113 rather than make an entire exception for mIRC, choose 'TCP'.

If you have a router and you need to forward port 113, then it depends on the router you have. It's a good idea to read the manual, however, see if your router is listed at http://www.portforward.com/routers.htm and see if they have instructions for yours. (Thanks Danthemandoo for that link)

The latest versions of Norton Antivirus have an "Internet Worm Protection" feature which may block port 113. To disable it, open NAV and click on 'Options'. Under 'Internet' go to 'Internet Worm Protection' and uncheck the box.

If identd has worked for you in the past and suddenly isn't on DALnet, read http://toidyman.net/identd.html.

If you are receiving an error message such as this:

"Your username is invalid.
Connect with your real username, in lowercase.
If your mail address were foo@bar.com, your username would be foo."


Or

"Closing Link: 0.0.0.0 (Invalid username [ ])"

..then you will need to edit your E-mail address settings or your IdentD. Make sure that you are not using any special characters such as $, %, ^, * in your email address or IdentD. To check your email address settings go to ALT+O > Connect and check the email address box.
To check your IdentD settings go to ALT+O > Connect > IdentD. Check the box next to 'User ID'.

Also make sure that everything in both those boxes is in lowercase (no CAPS). If it still doesn't work then try removing numbers and double check you have no other special characters. Remember that a script or a virus could be changing your IdentD automatically and that could be causing you problems. If it's a script you will need to unload the script from your remotes. If you think it may be a virus then see this thread and use 2-3 virus scanners to secure your system.

If the problem still persists then you're going to need to contact the network administration. Remember, this error message isn't given to you by mIRC, mIRC is just a client. The server of the network is actively refusing your connection due to your settings. You will need to go to your network's website and look for contact emails. If you don't know the network's website, search on Google.

You can find further help with this error message on this page. If you are a GameSurge user see their forums. If you are a Quakenet user see this page.
Posted By: erikw

Using Triggered Ports - 08/10/03 01:55 PM

Some routers will let you use triggered port mapping. It allows incoming port 113 connections to go to multiple computers on your network. That way you can use mIRC from multiple computers. Triggered port mapping listens for messages from your computers, that have a specific destination port, or range of ports.

For example, you can tell the router to trigger a port mapping when it sees a connection message for port 6667, which is usually how you connect to an IRC server. You also tell the router to map port 113 to any computer that causes the trigger.

Unfortunately some routers don't have the triggered port feature, or it doesn't work right with port 113. I'm not sure why port 113 is such a problem, but please complain to the router manufacturer if they don't support port 113, or it doesn't work correctly.
Posted By: sailor_olimpus

Re: enable identd - 02/01/04 12:47 PM

i don't know what to do, i've working with irc.mircx.com and this is the first time, several people told me that maybe i'm banned, but why? i didn't do anything!!! please help me!
Posted By: ParaBrat

Re: enable identd - 03/01/04 09:24 PM

Without knowing exactly what is happening to you, its hard to just guess. What exactly happens? What msgs do you get?

If its a msg telling you to enable identd, some networks have had so many probs from users from certain providers that they insist all users from those providers (the ppl you pay for your internet service) enable identd.

Banning may not be aimed at you specifically, but on all ppl within a certain ip range and you are getting caught in it.
Posted By: sailor_olimpus

Re: enable identd - 05/01/04 11:20 AM

thanks for answering!
Posted By: ParaBrat

Re: enable identd - 05/01/04 08:52 PM

you're welcome!
Posted By: KST

Re: enable identd - 06/01/04 09:53 PM

I have question about trigger port
what do i put in "Trigger Start Port" box and "Trigger End port" and Public port ??? Thanks for your help ..
Posted By: LillyLan422

Re: enable identd - 14/01/04 01:42 AM

Hi! I have a question on identd. I was told to identify or identd myself with mIRC. I ve tried everything to identd myself through mIRC help and through the website you had posted. But nothing works. I'm getting 'No Ident response' when I connect to mIRC. How can I identd myself? Please help!
Posted By: Doqnach

Re: enable identd - 14/01/04 01:46 AM

it is possible that you use a firewall/router which does not let you use the identd. you need port 113 open for relay

for most networks it's no problem if you can't ident, it just uses the part in front of the @ of the email address you filled in.

make sure that the part in front of the @ of that email address is all lowercase without any special characters to be sure it works
Posted By: LillyLan422

Re: enable identd - 14/01/04 05:23 AM

Hi! It's me again. Okay, I did what you said. But what happen if the part in front of the @ of the email address I filled in is short by one word or number in the mIRC option/connection/Identd.
This is what it said when I connect.

-irc.mircx.com- *** Looking up your hostname...
-
-irc.mircx.com- *** Found your hostname, cached
-
-irc.mircx.com- *** Checking Ident
-
-irc.mircx.com- *** No Ident response

Thank alot for helping!!!
Posted By: Zyzzyx26

Re: enable identd - 15/02/04 12:36 PM

Hello there smile

I was pointed to this forum by a friend, who was helping me with my identd problem.
I have a network here at home...just 3 computers. If i connect as the main computer, i get identified, but my Userid is not the one i set.
If i connect as the client, i don't get identified, but my Userid remains as the one i set. What's going on?
I have a proxy program called AnalogX., no firewall and my router doesnt block the port 113 (i checked already smile
Help me please! Thanks smile
Posted By: whoa

Re: enable identd - 19/02/04 05:27 AM

thanks is good

[08:13] -dragons.ca.us.dal.net- *** Got Ident response
- cool
Posted By: worfking

Re: enable identd - 22/02/04 05:39 PM

i have a d-link 614 router and have no problems irc or irq for that matter.
Posted By: yujin

identd errors - 31/03/04 07:34 AM

hi, i posted a message but i get it got lose, hopefully i am not double posting.
I have a problem connecting to channel everything i do, it say
"you must register or identify to you nickname to enter this channel"
i have register and indendt my nickname.
can anyone help me
Posted By: Mentality

Re: identd errors - 31/03/04 06:33 PM

That message is unrelated to IdentD.

Some networks have a +R (or +r) channel mode which means only registered/identified users can join - not all networks have this.

The problem might be a desynch. Reconnect to a different server (try /links for a list) and then identify again. Also make sure you use your registered nickname and that you don't just identify from a nickname different from your registered one.

Their may be other factors involved for the network you use - we are not affiliated with any one channel, server or network and so can't possible know about all of them. The best thing to do is to ask in the network's #Help channel or check out the network's website. If you don't know the website address, search Google.

Best of luck smile

Regards,
Posted By: Miss_R

enable identd/autokill - 08/04/04 11:18 AM

hello its me again i cant still connect to mirc dalnet. im using windowsxp and the problem is everytime i want to chat mirc it always say you are not welcome on this network you have been autokilled no ident response. dragons.ca.us.dal.net- *** autokilled for [AKILL ID:1044655424K-a] [exp/identd] IRC clients from your domain are required to respond to identd requests in order to connect to DALnet. Send email to exploits@dal.net with [exp/ident] as the subject for more information. (2004/04/05 15.49) this are the message that comes up on my screen pls help me. i would appreciate any help pls. thank u
-

Posted By: sparta

Re: enable identd/autokill - 08/04/04 01:08 PM

try type in your status window: /identd on som_ident
Posted By: ParaBrat

Re: enable identd/autokill - 09/04/04 03:57 AM

as the first post on this thread says, also be sure you arent blocking port 113
Posted By: oskari

Re: enable identd - 22/04/04 02:07 PM

I've been trying to configure my system to work with the servers requiring identd. Other servers let me in using mIRC 6.14.

My system is WINXP prof, and I am using F-Secure client (I've tried also F-S client unmounted)

I have configured WINXP's firewall according to advice found inin this thread, but identd not working.

The network I am accessing internet is an open access WLAN, which seems to use DHCP.

Is there any solution to my identd problem or is this a gateway issue??
Posted By: DamienH

Re: enable identd - 23/09/04 08:08 PM

Hey when i try to enable i ident upon connecting i get this message

amsterdam2.nl.eu.undernet.org- *** Looking up your hostname
-
-amsterdam2.nl.eu.undernet.org- *** Checking Ident
-
-amsterdam2.nl.eu.undernet.org- *** Your forward and reverse DNS do not match, ignoring hostname.

Does anyone know what the problem could be??? I'm sure I have it set up right as long as it's just all in the options menu?
Posted By: wiebe

Re: enable identd - 23/09/04 09:16 PM

that is not related to ident.
"Your forward and reverse DNS do not match, ignoring hostname."
means: resolving from ip to host, and from host to ip gives different results for your ip. as a result you appear on irc with an ip and not a hostname.

wiebe
Posted By: Embellisher

Re: enable identd (BellSouth DSL customers only) - 23/10/04 10:28 PM

If you use Bellsouth as your ISP, and keep getting the "Enable Identd" error message in mIRC, be aware that in addition to configuring mIRC to use the same ports that you told the Windows Firewall to use, you need to tell your DSL modem to allow traffic on port 113 (Identd, TCP). See BellSouth's notice on http://www.broadbandreports.com/faq/10754
Posted By: SweetCrys

Re: enable identd (BellSouth DSL customers only) - 21/12/04 12:23 PM

ok ok i got it... or at least... i think so... i have the same problem with identd:
* Connecting to graz2.at.eu.undernet.org (6661)
-
-graz2.at.eu.undernet.org- *** Looking up your hostname
-
-graz2.at.eu.undernet.org- *** Checking Ident
-
-graz2.at.eu.undernet.org- *** Couldn't look up your hostname
-
-graz2.at.eu.undernet.org- *** No ident response
-
Ping? Pong!
-
[59] Please install identd to identify abusers.
-
Closing Link: o_dulcica by Bucharest.Ro.Eu.Undernet.Org (G-lined)
so..... i followed your link.... the one from the first poste http://kline.dal.net/exploits/winident.htm and.... they tell me to fill in with my User ID. where do i get ir from? confused
Posted By: ParaBrat

Re: enable identd (BellSouth DSL customers only) - 21/12/04 09:24 PM

your user id is what you see under view-->options-->connect-->identd on the UserID line. generally its a good idea to have that be the same as what you see before the @ under view-->options-->connect, the email addy line. Note that it doesnt have to be your name, in fact its best not to have your real name there, most ppl put something silly (like mine says fatchance)
Posted By: SweetCrys

Re: enable identd (BellSouth DSL customers only) - 22/12/04 06:42 AM

well.... thanks but.... i set my identd on sweet and my email addres is sweet@ ..... but.... the problem is still there crazy
Posted By: yatta

Re: enable identd (BellSouth DSL customers only) - 02/01/05 04:40 AM

I am also having this problem, but it only happens sometimes.
Posted By: blazeWCR

Re: enable identd - 05/08/05 12:02 AM

[19:58] * Connecting to irc.quakenet.org (6669)
-
[19:58] -irc.quakenet.org- *** Looking up your hostname
-
[19:58] -irc.quakenet.org- *** Checking Ident
-
[19:58] -irc.quakenet.org- *** Found your hostname
-
[19:58] -irc.quakenet.org- *** No ident response


That's the error I get (from Quakenet). My Identid and all that jazz is set up, port 113 is forwarded etc on both my router and on Windows XP firewall. There is no way to contact the Quakenet support people, as their help channel is on Quakenet and they have no email.

The odd thing is, every so often it lets me connect, but it's after about 2 dozen tries. There's got to be a way to fix this thing.
Posted By: blazeWCR

Re: enable identd - 31/08/05 03:38 PM

Annnnnyone at all?
Posted By: _dood_

Re: enable identd - 31/08/05 06:36 PM

Try opening port 133 on your firewall.

If you are behnd a router, make sure it is forwarded to your computer.
Posted By: _dood_

Re: enable identd - 31/08/05 06:36 PM

Try opening port 113 on your firewall.

If you are behnd a router, make sure it is forwarded to your computer.
Posted By: Riamus2

Re: enable identd - 31/08/05 07:38 PM

If you can't get ident to work for whatever reason, then find out WHICH servers on that network allow you to connect without the ident and only try to connect to those servers.
Posted By: RusselB

Re: enable identd - 01/09/05 05:38 AM

Quakenet requires Identd from users on several large ISP's, and this requirement is network wide.
Posted By: Riamus2

Re: enable identd - 01/09/05 06:12 PM

He said he could connect once in awhile. It's more likely a server or two isn't following that rule than that his ident works randomly. I've been to many networks where ident is required on most, but not all servers (Efnet being one that did this in the past when I was unable to use identd. It may have changed since then, of course). I admit I've not been on quakenet, but I'm not sure why it would be any different.
Posted By: spookster810

Re: enable identd - 14/09/05 12:50 PM

Hi!

I'm running under WinXP and Mirc. My ISP is supossed to be running with a proxy.

I usually conect okay with Efnet and I've been downloading stuff from their channels for a while now, but today, I don't know why, I get this message:

-irc.blessed.net- *** Looking up your hostname...
-
-irc.blessed.net- *** Checking Ident
-
-irc.blessed.net- *** No Ident response
-
-irc.blessed.net- *** Found your hostname
-

I get it with any server I try. After getting it, I can connect, but with the ~ behind my nickname, and if I try to enter ANY channel, I find myself alone there.

I don't know what to do, I have tried disabling my antivirus, I have the Windows firewall turned off, and ZoneAlarm is set to allow anything to Mirc; I even oppened port 113 with telnet, and of course, I have the IDENT options correctly configured in Mirc, but I keep getting that message... What can I do, I'm desperated! I haven't changed anything since the last time I conected, why s this happening?

Is there any other way to enter Efnet channels that is not with Mirc?

Thanks a lot.
Posted By: Riamus2

Re: enable identd - 14/09/05 12:58 PM

Um... you don't open port 113 with telnet.... Look on http://www.portforward.com for information on forwarding/opening ports.

That response you see is normal when connecting when you don't have ident being sent for whatever reason. It doesn't mean you can't connect or are not allowed on the network.

As far as channels being empty, perhaps there is a netsplit. Or, perhaps channels were shut down by Efnet for illegal filesharing (something we won't help you with).
Posted By: spookster810

Re: enable identd - 14/09/05 01:56 PM

No, the channels are not closed, I know my friends are entering them and they are full. And don't worry, it's nothing illegal about it, I'm not talking about dl music or anything wink

I tried forwarding the port 113, but still the same... It's almost like telnet , anyway, isn't it?

Maybe it's because of a proxy in my ISP?

Thanks again.
Posted By: Riamus2

Re: enable identd - 14/09/05 02:13 PM

Yes, a proxy could prevent the ident from working properly.
Posted By: spookster810

Re: enable identd - 14/09/05 02:55 PM

Great mad Then, considering nothing else works, I gues sthat must be the problem, although it's weird, because I have had the same ISP (hence the same proxy) for a while, and Efnet used to work properly...

Anyway, there's not other way to connect to Efnet channels, right? No other program? Or should I be able to connect, and what's weird is the fact that I find the channels empty?

Sorry to keep bothering you wink Thanks heaps.
Posted By: Riamus2

Re: enable identd - 14/09/05 03:42 PM

Well, you ARE connecting, so it doesn't matter if ident is working properly. As for why you can't see anyone in the channel, I'm not sure. Have you tried joining #help and seeing if anyone is there?
Posted By: spookster810

Re: enable identd - 14/09/05 05:28 PM

Mmmhhh... Weird, I just tried to join help, and it's full... I don't know what's wrong, but at least it seems the problem is related to the channel itself. Maybe because you can't enter that channel with ANY efnet server?

Thanks a lot, you've cleared my mind smile
Posted By: Riamus2

Re: enable identd - 14/09/05 05:55 PM

As I said earlier, it could simply be a netsplit.
Posted By: spookster810

Re: enable identd - 14/09/05 08:16 PM

Maybe... last question, I swera: is a netsplit definitive?

Thanks once and again.
Posted By: Riamus2

Re: enable identd - 15/09/05 12:45 PM

Definitive?
Posted By: spookster810

Re: enable identd - 16/09/05 01:57 PM

Mmmhh... Spell? I mean if that situation can change... as in something like "unsplit"?? Sorry about my english wink
Posted By: Riamus2

Re: enable identd - 16/09/05 03:21 PM

Yes, a netsplit is almost always temporary. Of course, "temporary" can be anything from seconds to hours or more. Most last under 15 minutes.

You can get around a netsplit by just connecting to a server that is on the other "side" of the split.

Example:

5 servers are in a network and you connect to server #5. If a netsplit happens to #5, then everyone connected to #5 will no longer be able to see anyone connected to servers #1-4, and those on servers #1-4 won't see anyone on server #5. If you then go and connect to one of the #1-4 servers, you'd see everyone on those servers, but not on #5.

Depending on who is connected on each server and what channels they are in, you can very easily end up being the only person in a specific channel on server #5, so it will appear empty.

Of course, that's a basic example... netsplits can take out more than one server at a time, and you can even have multiple different splits, so that there are more than 2 sides to the split.
Posted By: spookster810

Re: enable identd - 16/09/05 07:37 PM

Thanks, perfectly clear now smile
Posted By: hughanew080

Re: enable identd - 27/03/08 06:55 AM

I am having ident problems, too, but the things being discussed on this forum are greek to me. Is there someone who can call me?
Posted By: spider633

Re: enable identd - 24/08/10 01:12 AM

i am having trouble with my Ident..

it used to work fine, but now it doesnt...i dont know why..here is what i get now

* Connecting to irc.link-net.org (+7000)
-
-irc.link-net.org- *** Looking up your hostname...
-
-irc.link-net.org- *** Checking Ident
-
-irc.link-net.org- *** Couldn't look up your hostname
-
-irc.link-net.org- *** No Ident response
-
Ping? Pong!

i have done all the port fowarding steps, like i have said it used to work...can any one help me?? thanks
Posted By: izzie

Re: enable identd - 15/02/12 08:26 PM

I have a similar issue. Most times when I connect (via Mirc) to Undernet, I get this:

[INFO] Connecting to [url=irc://undernet/][url=irc://undernet/][url=irc://undernet/]irc://undernet/[/url][/url][/url] ([url=irc://irc.undernet.org/][url=irc://irc.undernet.org/][url=irc://irc.undernet.org/]irc://irc.undernet.org/[/url][/url][/url]) [Cancel]
=== *** Looking up your hostname
=== *** Checking Ident
=== *** Found your hostname
=== ddgaucho Register first.
=== *** No ident response
=== *** Ident broken or disabled, to continue to connect you must type /QUOTE PASS 10783

after I type the necessary stuff, I connect just fine. It just annoys me. What am I doing wrong? This has happened with all versions of Mirc and Chatzilla.
Posted By: Riamus2

Re: enable identd - 16/02/12 12:15 PM

As it says, the server isn't receiving an identd response, so that specific network requires you to use /quote to avoid spam bots. Make sure that identd is enabled in mIRC and also make sure that port 113 is not blocked in any firewall or router that you're using. This is explained in the first post of this thread.
Posted By: Rainman_mark

Re: enable identd - 26/02/13 05:04 AM

what do i put in "Trigger Start Port" box and "Trigger End port" and Public port ?
Posted By: KindOne

Re: enable identd - 26/02/13 04:57 PM

For my router/modem combo, I do:

Start port: 113
End port: 113
© 2021 mIRC Discussion Forums