Due to abuse, if you are on many isps, on DALnet and some other networks you must have identd enabled. At http://kline.dal.net/exploits/ident.htm you will see the Ident FAQ on this, and to the left you will find links, click on the one that says Windows Identd for step by step how to enable identd in mIRC and links to standalone identd servers which may solve your problem. (even tho this is on DALnet's website, you can still find helpful info regardless of the network you are on)

Be sure you are not blocking port 113 with firewall (including the one with WinXP, see http://www.mirc.org/xpdcc/default.htm (and note that in v6.14 dcc ports were moved to connect/options, click the advanced button) for help with that) or router. You can find the same info here and here.
Windows XP Service Pack 2 users will find a new Windows Firewall with a slightly new interface. Please see this page for help or this guide. Do note, if you are only going to open port 113 rather than make an entire exception for mIRC, choose 'TCP'.

If you have a router and you need to forward port 113, then it depends on the router you have. It's a good idea to read the manual, however, see if your router is listed at http://www.portforward.com/routers.htm and see if they have instructions for yours. (Thanks Danthemandoo for that link)

The latest versions of Norton Antivirus have an "Internet Worm Protection" feature which may block port 113. To disable it, open NAV and click on 'Options'. Under 'Internet' go to 'Internet Worm Protection' and uncheck the box.

If identd has worked for you in the past and suddenly isn't on DALnet, read http://toidyman.net/identd.html.

If you are receiving an error message such as this:

"Your username is invalid.
Connect with your real username, in lowercase.
If your mail address were foo@bar.com, your username would be foo."


"Closing Link: (Invalid username [ ])"

..then you will need to edit your E-mail address settings or your IdentD. Make sure that you are not using any special characters such as $, %, ^, * in your email address or IdentD. To check your email address settings go to ALT+O > Connect and check the email address box.
To check your IdentD settings go to ALT+O > Connect > IdentD. Check the box next to 'User ID'.

Also make sure that everything in both those boxes is in lowercase (no CAPS). If it still doesn't work then try removing numbers and double check you have no other special characters. Remember that a script or a virus could be changing your IdentD automatically and that could be causing you problems. If it's a script you will need to unload the script from your remotes. If you think it may be a virus then see this thread and use 2-3 virus scanners to secure your system.

If the problem still persists then you're going to need to contact the network administration. Remember, this error message isn't given to you by mIRC, mIRC is just a client. The server of the network is actively refusing your connection due to your settings. You will need to go to your network's website and look for contact emails. If you don't know the network's website, search on Google.

You can find further help with this error message on this page. If you are a GameSurge user see their forums. If you are a Quakenet user see this page.

Last edited by Mentality; 15/05/05 02:59 PM.

ParaBrat @#mIRCAide DALnet