I have the same problem connecting to certain fserves. It only happens to me when i get .rar files. Is there any way to change that? My ignore is disabled and .rar is not in the ignored part of my options. I can get any other file from an fserve that I can't get a .rar from.