Would you consider relabeling "Method" to "Authentication"? Otherwise "Auth Method" or "Auth Type"? It's hard to explain to people since it doesn't convey context.
Well. At least I won lunch.
Good philosophy, see good in bad, I like!