You can fix the line number issue under WINE (plus a couple of other bugs including the Remote tab crash bug) by disabling the richedit20 library when running mIRC. If you don't know how to do that, follow the steps below:

  • Run winecfg from the command-line.
  • Add mIRC to the application settings list
  • Select mIRC in the list (the dialog's titlebar should change to say "Wine configuration for mirc.exe")
  • Go to the Libraries tab
  • Select richedit20 from the overrides dropdown and press Add to add it to the override listbox
  • Select richedit20 in the override listbox and press Edit
  • Select Disable in the dialog and press OK
  • Press OK in the winecfg dialog

The line numbers should display just fine now under WINE. The only bug I've experienced from doing this is that pressing return in the Script Editor seems to add two new lines instead of one. Not ideal, but at least you can see what's in the box now.

Spelling mistakes, grammatical errors, and stupid comments are intentional.