Admittedly I haven't made the effort to see if some of these bugs have been reported already, but I have a small list of some thing that I have noticed and caused me to frown upon v7.x.
  • SSL Sockets
  • Evaluation of $chr(173) (there might be other ASCII character associated with this)
  • Associating correct ports with their respective Server Connections upon startup of mIRC
Regarding the first item, SSL Sockets, I am referring to SSL capabilities associated with /sockopen -e. The connection that I was able to establish only lasted for a matter of seconds (most likely less than 2 full seconds).

The second item, evaluation of $chr(173), was encountered when I tried to remove a ban that was set that contained a series of ASCII characters, 173 included. It is not possible (from what I have tried) to remove the ban on v7.1, but there is no problem removing it when on v6.35.

Using this alias
alias chr { echo 4 -a $qt($1-) == $!+( $+ $left($regsubex($1-,/(.)/g, $+($,chr,( $+ $asc(\1) $+ ),$chr(44))),-1) $+ ) }
I did the following test: //chr $chr(173)

On mIRC v6.35, it returns: $+($chr(173))
On mIRC v7.1, it returns: $+($chr(194),$chr(173))

mIRC appears to "append" this extra character wherever $chr(173) is present in v7.1, making dealing with $chr(173) by itself extremely difficult, if not impossible.

And finally my last observed bug can be found during a simple start up of mIRC. Currently in v7.1, the port of the last connection is used (prior to exiting mIRC) is used automatically even if you select a Server from the list found under "History" in the File menu. #mSL,#xmrfunny1x