It returns this in the status window:

>TOPICS triggered

But nothing happens.

Same happens when I tried as you said;

alias topics1 { echo -s >TOPICS triggered | scon -at1 echotopics1 }
alias -l echotopics1 {
  echo -s >ECHOTOPICS1 triggered
  var %n = $chan(0)
  echo -s >CHAN(0) is $chan(0)
  while (%n) {
    echo $color(Topic text) -t $chan(%n) $+(* Topic is ',$chan(%n).topic,')
    echo -s >N is %n
    dec %n

But I run 2 identical versions of mIRC. As I connect to like 13 servers. Got one main mIRC, and one more to house the rest of the channels.. So I see no reason why it works in one of them, but not in the other..

Only difference I know of for sure, is that in my "main" mIRC, I am on 4 servers, and not so many channels.. But in the "other" I am on 9 severs, and a whole LOT of channels.

Might that be the problem? Edit: I disscoented from all but 3 servers, and tested the script, but it did not work.

Strange stuff..

Last edited by gomp; 25/06/10 12:01 PM.

I do not speak English. I speak Norwegian. So please bear with my poor English spelling and grammar.