That doesn't match any existing mIRC syntax. I think it's a bad idea to bring in things like that. There should be a level of consistency.

foreach (%nick,$nick($chan,rovha)) {


The above would at least be similar to what exists already. To be honest though, I don't see the point in a foreach loop for mIRC. foreach is really something I'd only consider useful in an OOP language.

In the above example, how would mIRC know where to put to put the incrementation variable? ($nick($chan,N,rovha))
Unless you're suggesting that $nick($chan,rovha) return an array/collection, which would need to be implemented first.