mIRC Home    About    Download    Register    News    Help

Print Thread
In Need of DCC Send Help. #257733 12/05/16 10:13 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
I upgraded from mIRC v6.35, to mIRC v7.44, then to mIRC v7.45. I manually set The DCC Ports to: 4000 - 4020, and they are forwarded in the router to my local IP.

The problem is in mIRC v7.44 and mIRC v7.45. When I DCC Send, the file starts sending and stops for no reason after a few moments. I have checked everything I can think of to no avail. I'm a long time mIRC user, I work with windows networks and I know how to use DMZ and Port Forwarding in the router.

mIRC v6.35 worked and so did mIRC v7.44 (for a while). What am I missing? I'm running Win 7 64Bit Ultimate.

Re: In Need of DCC Send Help. [Re: TechChaos] #257734 12/05/16 10:19 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
Things I have tried:


Passive DCC
Changing the CPS Values
Turning off firewalls
Putting local IP in the DMZ..
Connecting PC strait to the modem.

Same results for each..

Re: In Need of DCC Send Help. [Re: TechChaos] #257737 13/05/16 03:07 PM
Joined: Feb 2009
Posts: 20
W
WKN Offline
Ameglian cow
Offline
Ameglian cow
W
Joined: Feb 2009
Posts: 20
Hi,

maybe in Options.Connect.Local you have a wrong public IP configured in IP address?

Check there at least On connect, always get IP address and test Lookup methods Normal or Server, whats serving you best.

BR
WKN

Re: In Need of DCC Send Help. [Re: WKN] #257741 13/05/16 05:43 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
Well if that was the case, it wouldn't start sending would it?

Re: In Need of DCC Send Help. [Re: TechChaos] #257742 13/05/16 05:52 PM
Joined: Jul 2006
Posts: 3,568
W
Wims Offline
Hoopy frood
Offline
Hoopy frood
W
Joined: Jul 2006
Posts: 3,568
Only Khaled can tell for sure but it's likely that literally nothing changed in the DCC routine.
A lot of people on mIRC 7.44 and mIRC 7.45 are using dcc send without any problem and you said it worked on 7.44 for a while.
These are very meaningful, it is likely your configuration that changed, for instance it could be your antivirus software causing it, could be some firewalls (windows/router).
The fact that it starts sending correctly and then stop suggests an AV software issue.
If you try to disable your AV software and install mIRC 7.45 in a new empty folder using the portable option, is it working?

Last edited by Wims; 13/05/16 05:53 PM.

Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net
Re: In Need of DCC Send Help. [Re: TechChaos] #257743 13/05/16 07:44 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
I reinstalled v6.35 and the DCC sends work 100% perfectly. The DCC Sends, in the latest versions start then stop after a few short moments. All settings are the same in both when running just one mIRC. Looks like I'm just going to have to downgrade until a solution is found.

Re: In Need of DCC Send Help. [Re: Wims] #257744 13/05/16 07:47 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
I'll try disabling the AV and see..

Re: In Need of DCC Send Help. [Re: TechChaos] #257745 13/05/16 07:52 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
Disabling the AV (Avast), don't affect the DCC Sends. It starts and shortly after it fails. "Transfer Incomplete", is all it tells me.

Re: In Need of DCC Send Help. [Re: Wims] #257746 13/05/16 07:55 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
I always use the portable option. And I have just installed the latest version from mirc.com in C:\mIRC. Same problem..

Re: In Need of DCC Send Help. [Re: TechChaos] #257748 13/05/16 08:11 PM
Joined: Dec 2002
Posts: 4,544
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,544
I just tested mIRC v7.45 and it worked fine for me. I set the port range in the mIRC Ports dialog, opened up that port range on my router, ran a second copy of mIRC on a another computer on a different IP address, and was able to send files from the first mIRC to the second mIRC without any issues. I also tested Passive DCC on the second mIRC and was able to send to the first mIRC without any issues.

Do you have UPnP support enabled in mIRC v7.45? If you disable that, does that help?

Re: In Need of DCC Send Help. [Re: Khaled] #257749 13/05/16 08:30 PM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
Ok it appears it was the AV, I just added an exclusion for C:\mIRC, and all is good. smile thanks for your help! and fast reply's! smile

Re: In Need of DCC Send Help. [Re: TechChaos] #258059 07/06/16 02:30 AM
Joined: May 2016
Posts: 10
T
TechChaos Offline OP
Pikka bird
OP Offline
Pikka bird
T
Joined: May 2016
Posts: 10
Strange.. same problem is back again. lol The exception is still in AV. I WILL FIGURE THIS OUT! :-/
Turning off AV and Firewall has no effects..

Last edited by TechChaos; 07/06/16 02:32 AM.