mIRC Home    About    Download    Register    News    Help

Print Thread
Unable to connect, DCC session closed #240166 30/12/12 09:47 PM
Joined: Dec 2012
Posts: 4
P
pante000 Offline OP
Self-satisified door
OP Offline
Self-satisified door
P
Joined: Dec 2012
Posts: 4
Hi!

I installed Eggdrop bot. I setted up master password to my Eggdrop bot via mIRC.
I start dcc with this command: /ctcp _Xbot chat
But I get an error message:
Code:
DCC Chat session 
- 
Client: _Xbot (79.133.201.66) 
Time: Sun Dec 30 21:40:04 2012 
- 
Acknowledging chat request... 
- 
Unable to connect 
- 
DCC session closed


Whats the real problem? How to I connect to my bot with dcc via mIRC?

Thank you!

Re: Unable to connect, DCC session closed [Re: pante000] #240167 30/12/12 10:15 PM
Joined: Aug 2012
Posts: 57
Maelish Offline
Babel fish
Offline
Babel fish
Joined: Aug 2012
Posts: 57
Did mirc connect before without the bot? Try uninstalling the bot and starting from scratch.


Find Gamers, my player finder for tabletop RPGers and Wargamers.
Re: Unable to connect, DCC session closed [Re: pante000] #240171 30/12/12 10:48 PM
Joined: Feb 2003
Posts: 3,432
S
sparta Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Feb 2003
Posts: 3,432
If others can DCC to the bot, then try set your ip by hand.

tools/options click ports, enter your IP and try DCC again. Maybe that will help.


if ($me != tired) { return } | else { echo -a Get a pot of coffee now $+($me,.) }
Re: Unable to connect, DCC session closed [Re: pante000] #240177 01/01/13 11:23 AM
Joined: Dec 2012
Posts: 4
P
pante000 Offline OP
Self-satisified door
OP Offline
Self-satisified door
P
Joined: Dec 2012
Posts: 4
I tried xdcc send command on another bot (its not mine), it works fine.
So that mean, my Eggdrop bot's config is bad and my mIrc is good?

Re: Unable to connect, DCC session closed [Re: pante000] #240178 01/01/13 05:52 PM
Joined: Feb 2003
Posts: 3,432
S
sparta Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Feb 2003
Posts: 3,432
You need to tell the config file what IP to use, if it's behind a router you need to forward the port to your eggdrop.


if ($me != tired) { return } | else { echo -a Get a pot of coffee now $+($me,.) }
Re: Unable to connect, DCC session closed [Re: sparta] #240179 01/01/13 09:31 PM
Joined: Dec 2012
Posts: 4
P
pante000 Offline OP
Self-satisified door
OP Offline
Self-satisified door
P
Joined: Dec 2012
Posts: 4
Okay, thank you!
What will I tell?
I use Dlink wifi router, my ip is dinamic (cause of adsl): 81.182.xx.xxx
My settings on mIRC: http://i.imgur.com/uEK4W.png
Firewall add mirc.exe
Router ip: 192.168.0.1
Pc ip: 192.168.0.11

Re: Unable to connect, DCC session closed [Re: pante000] #240180 01/01/13 10:17 PM
Joined: Feb 2003
Posts: 3,432
S
sparta Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Feb 2003
Posts: 3,432
set my-hostname "" <- here you put the hostname for the bot.
set my-ip "" <- here you put the IP of the eggdrop.

And make shure you have the right flag in the bot, i think it is +p you need to be able to DCC the bot.


if ($me != tired) { return } | else { echo -a Get a pot of coffee now $+($me,.) }
Re: Unable to connect, DCC session closed [Re: sparta] #240183 02/01/13 07:17 PM
Joined: Dec 2012
Posts: 4
P
pante000 Offline OP
Self-satisified door
OP Offline
Self-satisified door
P
Joined: Dec 2012
Posts: 4
I tried these, but not working.

Re: Unable to connect, DCC session closed [Re: pante000] #240184 02/01/13 08:47 PM
Joined: Mar 2004
Posts: 526
HorseC Offline
Fjord artisan
Offline
Fjord artisan
Joined: Mar 2004
Posts: 526
when you have a router in the mix make sure you are port forwarding ports to mirc (i suggest 5 ports or so) and then make sure in mirc options you set the same ports! also make sure you port forward 113 used for dcc acks for dcc back. good luck


Help others! It makes the world a better place, Makes you feel good, and makes you Healthy!