mIRC Home    About    Download    Register    News    Help

Print Thread
[7.0 beta 16] Timestamp with unicode characters #220188 07/04/10 03:11 AM
Joined: Aug 2007
Posts: 12
E
eXonyte Offline OP
Pikka bird
OP Offline
Pikka bird
E
Joined: Aug 2007
Posts: 12
Setting the timestamp format to have a character in it no longer works properly whether set in the Options dialog or via /timestamp -f. The timestamp is set, viewable both in the Options dialog and via $timestampfmt but the actual timestamp displayed in the channel is the default [HH:nn]. $timestamp also returns the [HH:nn] style timestamp.

Re: [7.0 beta 16] Timestamp with unicode characters [Re: eXonyte] #220193 07/04/10 07:16 AM
Joined: Oct 2003
Posts: 3,918
A
argv0 Offline
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
Confirmed on Win7 64bit


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Re: [7.0 beta 16] Timestamp with unicode characters [Re: argv0] #220198 07/04/10 01:33 PM
Joined: Aug 2007
Posts: 12
E
eXonyte Offline OP
Pikka bird
OP Offline
Pikka bird
E
Joined: Aug 2007
Posts: 12
Thanks for reminding me: I forgot to include that I'm on Win7 x64 also.

I also just discovered that the same time format supplied to $asctime() is returning $null.

Last edited by eXonyte; 07/04/10 02:02 PM.
Re: [7.0 beta 16] Timestamp with unicode characters [Re: eXonyte] #220220 07/04/10 08:36 PM
Joined: Dec 2002
Posts: 5,150
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,150
Thanks, it turns out that some CRT library time-related functions fail to work if a string contains a unicode character. I have changed my time evaluation routine to get around this in the next version.