Hi Khaled,
I was unaware that Windows 10 would hide inactive icons.

Disabled - Always show all icons in the notification area

I enabled the mIRC icon, so it would display in the active notification area.

All options are checked in mIRC tray options
Check - Always show mirc icon
Check - On startup minimize mirc
Check - Place mirc in the tray when minimized
Check - Animate Icon
Check - Single click

Running the beta version, I haven't noticed any issues yet. I will report back later in the week after using Remote Desktop to see if that causes any additional symptoms.

Thank you,