Thanks for your bug report. I have not been able to reproduce this issue so far. What are your settings in the Tray dialog in mIRC?

In Windows 10, tray icons are now considered notification icons, so they are treated differently than they were in previous versions of Windows. It is possible that Windows 10 may be hiding inactive icons automatically. Have you checked your tray icon notification settings in Windows 10? Right-click on an empty space on the Windows taskbar, select "TaskBar Settings", scroll down to "Notification Area", and customize settings.