...

Here the deal: mIRC does not behave the way you described by default, therefore it's either a script, a mIRC's setting, or a bug.
You were asked to try /remote off to see if it were a script, you never answered that question, having only one remote file loaded is enough, assuming it's nothing of importance is an assumption only and could be the problem here, you should have tried /remote off in the first place and reported the result back here.
Anyway, it didn't seem to be the problem, so what is left? Settings:
Riamus2 made a good point that has been, for some reasons, totally overlooked, but it's likely the problem here, go to the options (alt + o > irc > options > event's'button) and check that you are not hidding on quit event.


Looking for a good help channel about mIRC? Check #mircscripting @ irc.swiftirc.net