mIRC Home    About    Download    Register    News    Help

Print Thread
/ignore -u not working as expected #47340 05/09/03 08:18 AM
Joined: Aug 2003
Posts: 37
R
rbhibbs Offline OP
Ameglian cow
OP Offline
Ameglian cow
R
Joined: Aug 2003
Posts: 37
tested with version 6.03

issue the following command in a script:

ignore -u $+ $1 $2 8 $chan

it generates the following response from mIRC:

* Updated ignore switches for test_nick!*test@*.dsl.lsan03.pachebel.net

but when I check the ignore list it shows:

test_nick!*test@*.dsl.lsan03.pachebel.net (pcntdik) <channel-name>

in other words, the "remove after n seconds" flag is not set.

When this was discussed some time back, the ignore hadn't taken effect because a query window was open -- in my testing only a channel window was open.

Also, I've tried this with timeout values 10, 30, and 60 seconds, all with the same result.

Re: /ignore -u not working as expected #47341 05/09/03 02:58 PM
Joined: Jun 2003
Posts: 32
WatchMinister Offline
Ameglian cow
Offline
Ameglian cow
Joined: Jun 2003
Posts: 32
try -u [ $+ [ $1 ] ] $2 8 $chan

Re: /ignore -u not working as expected #47342 05/09/03 07:17 PM
Joined: Aug 2003
Posts: 37
R
rbhibbs Offline OP
Ameglian cow
OP Offline
Ameglian cow
R
Joined: Aug 2003
Posts: 37

thanks for the suggestion, but unfortunately that did not work either

if I manually edit the ignore list using the mIRC editor, I can insert a "remove in x minutes" value, which apparently updates the entry -- which is removed by mIRC after the timeout interval -- but even when I force control.ini to be written to disk using /saveini, the entry for the the nick I just added to the ignore list DOES NOT have a value corresponding to the -u flag

this might be by design, after all, if control.ini is saved to disk with a timeout value, that value certainly is incorrect almost immediately, and I wouldn't expect the file to be rewritten once per second to keep it up to date

anybody have any other suggestions?

Re: /ignore -u not working as expected #47343 05/09/03 10:36 PM
Joined: Dec 2002
Posts: 1,527
L
landonsandor Offline
Hoopy frood
Offline
Hoopy frood
L
Joined: Dec 2002
Posts: 1,527
Do any of the following work?:

ignore $+(-u,$1) $2 8 $chan
ignore $+($chr(45),u,$1) $2 8 $chan

How is this getting entered in? It LOOKES like an alias, but I just wanna be sure the exact situation you use to fire the line off smile



Those who fail history are doomed to repeat it
Re: /ignore -u not working as expected #47344 06/09/03 12:43 AM
Joined: Aug 2003
Posts: 37
R
rbhibbs Offline OP
Ameglian cow
OP Offline
Ameglian cow
R
Joined: Aug 2003
Posts: 37
trying last two suggestions offered....

in aliases.ini:
/temp_ignore ignore $+(-u, $1) $2 8 $chan

then, invoked by:
/temp_ignore 180 test_nick

mIRC reported:
* Added test_nick!*test@*.dsl.lsan03.pachebel.net to ignore list for 180 secs

but... using the address book editor to examine the ignore list showed the following:
test_nick!*test@*.dsl.lsan03.pachebel.net (pcntdik) - #test_channel
...and when I selected that entry for editing, the "Remove in ___ mins" box was unchecked

also, mIRC did NOT time-out the ignore entry and remove it

I was curious if the remove mechanism works at all, so I manually edited the ignore list entry for a 3 minute timeout and waited....

checking at roughly one minute intervals, I could see that mIRC was decrementing the time remaining towards zero... eventually, mIRC timed-out the entry and removed it from the list

then, I altered the alias to be:
/temp_ignore ignore $+($chr(45), u, $1) $2 8 $chan

and invoked it again, after first verifying that the prior entry in the ignore list had been removed

same results as before, unfortunately

my conclusion: there are three differences between the expected behavior (from reading the help file) and actual behavior:

(1) the -u option, despite a message from mIRC indicating that the requested action has been taken, is completely ignored in practice

(2) the -u option specifies a time in seconds, but the address book editor specifies time in minutes

(3) manually editing the ignore entry to specify "Remove in ___ mins" does work -- I just can't figure out how to do this within an alias


Re: /ignore -u not working as expected #47345 06/09/03 01:37 AM
Joined: Aug 2003
Posts: 1,831
I
Iori Offline
Hoopy frood
Offline
Hoopy frood
I
Joined: Aug 2003
Posts: 1,831
Syntax smile

/ignore [-lrpcntikdwxu#] <on|off|nick/address> [type] [network]
Where p = private, c = channel, n = notice, t = ctcp, i = invite, k = control codes, d = dccs

There is no $chan parameter.
To ignore what the user says in channels, use the -c switch.
Code:
/temp_ignore ignore $+(-[color:blue]c[/color]u,$1) $2 8

Re: /ignore -u not working as expected #47346 06/09/03 06:32 PM
Joined: Dec 2002
Posts: 1,527
L
landonsandor Offline
Hoopy frood
Offline
Hoopy frood
L
Joined: Dec 2002
Posts: 1,527
OY! Now THIS I should have caught initially! I wonder if the $chan param is interfering with the timer option? As a side note, it would be nice if we did have a channel specific ignore option. I know the arguments are basically "if you want to ignore a (nick in a) channel, dont join it" vs "if you want to ignore the person in channels, use the "c" switch" vs "script the person's channel (specific) response(s) out" vs "we should be able to have a channel specific ignore system". Im NOT going to suggest this again cause obviously it has been suggested before, just making a comment about something in the original post smile


Those who fail history are doomed to repeat it
Re: /ignore -u not working as expected #47347 07/09/03 03:06 AM
Joined: Aug 2003
Posts: 37
R
rbhibbs Offline OP
Ameglian cow
OP Offline
Ameglian cow
R
Joined: Aug 2003
Posts: 37
very interesting.... thanks for pointing out the syntax error, but in this case the command description in the help file is wrong

I've been doing some experimenting, and /ignore WILL accept <network>, <channel>, or <server> as the last parameter, then the mIRC address book editor displays the parameter as it was entered, and control.ini is updated with the entered value

I suspect that mIRC is unable to know if a particular string is a network or server name, so simply permits any string as the final parameter

if the command is used WITHOUT the <network> parameter, the default value saved in control.ini is the SERVER name

if the -u<time> parameter is supplied AND the <network> name or <channel> name or any other string EXCEPT FOR THE CURRENT SERVER is supplied, the -u parameter is ignored by mIRC, so yes, the $chan value was interfering with the removal timer

also, mIRC rounds whatever value [in seconds] was supplied with the -u parameter to whole minutes

so, the help file should specify [server] instead of [network], and the timeout value used with -u is measured in minutes