mIRC Home    About    Download    Register    News    Help

Print Thread
Problem with setting font to bold on Action event #33130 30/06/03 05:44 AM
Joined: May 2003
Posts: 40
N
NiGHtOwL Offline OP
Ameglian cow
OP Offline
Ameglian cow
N
Joined: May 2003
Posts: 40
Hi there,
this is what I have:
Code:
on ^*:ACTION:*:*: { 
  /echo -mbflirt $iif(#,#,$nick) 7.:Action:.   $nick $1- 
  /haltdef
}


.
or this line as well
.


on ^*:ACTION:*:*: echo -mbflirt $iif(#,#,$nick) 7.:Action:.   $nick $1- | haltdef


on an on Action event the output should be:

.:Action:. >> Chatter got a huge headache

but what ever I try the font in the word .:Action:. stays normal, not bold.. like this:

.:Action:. >> Chatter got a huge headache

Any ideas what could be wrong here? Thanks for any suggestions.


gr33tz
NiGHtOwL
Re: Problem with setting font to bold on Action event #33131 30/06/03 05:53 AM
Joined: Dec 2002
Posts: 3,138
C
Collective Offline
Hoopy frood
Offline
Hoopy frood
C
Joined: Dec 2002
Posts: 3,138
Mm it work's fine for me..you sure you don't have a similar event above it?

Re: Problem with setting font to bold on Action event #33132 30/06/03 06:13 AM
Joined: May 2003
Posts: 215
lammkott Offline
Fjord artisan
Offline
Fjord artisan
Joined: May 2003
Posts: 215
Worked for me as well, if you've modified the timestamp using /timestamp -f check that you haven't ended it with a bold code.


- Jason
Re: Problem with setting font to bold on Action event #33133 30/06/03 06:24 AM
Joined: May 2003
Posts: 40
N
NiGHtOwL Offline OP
Ameglian cow
OP Offline
Ameglian cow
N
Joined: May 2003
Posts: 40
No other on Action event above it: just underneath somewhere an alias for $me when I do an action and that just works great, the output I would like to see.

Code:
alias me echo -ta 8.:Action:.  $me $1- | .me $1-


Yes I do have timestamp -f but not ending with a bold, it is ending with color.

Code:
on *:START:{
  timestamp -f 0.:15HH0:15nn0:15ss0:.
  splay -cw sounds/Op.wav
}


gr33tz
NiGHtOwL
Re: Problem with setting font to bold on Action event #33134 30/06/03 07:47 AM
Joined: Dec 2002
Posts: 3,547
S
SladeKraven Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Dec 2002
Posts: 3,547
Umm, is this any use to you?
Try here

Re: Problem with setting font to bold on Action event #33135 30/06/03 08:25 AM
Joined: May 2003
Posts: 40
N
NiGHtOwL Offline OP
Ameglian cow
OP Offline
Ameglian cow
N
Joined: May 2003
Posts: 40
Hey yes, that worked out, the bold font does show now and I could alter your code into the look I desired. Cool, thanks smile

Strange, that the other code is right as well, but shows that bug....


gr33tz
NiGHtOwL
Re: Problem with setting font to bold on Action event #33136 30/06/03 11:46 AM
Joined: Dec 2002
Posts: 3,547
S
SladeKraven Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Dec 2002
Posts: 3,547
You're welcome dude. smile

Re: Problem with setting font to bold on Action event #33137 30/06/03 11:58 AM
Joined: Dec 2002
Posts: 3,547
S
SladeKraven Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Dec 2002
Posts: 3,547
Hmmm; you could always use:
Code:
on ^*:ACTION:*:#: {
  echo -t $nick $chr(2) $+ $chr(3) $+ 7 $+ .:Action:. $+ $chr(3) $+ $chr(2)  $nick $1-
  haltdef 
}

Which would echo something like;
.:Action:. SladeKraven ...