First off, I know it has been discussed a lot already, but I'm having loads of trouble getting this to work.
As the title says, I've been trying to figure out how to solve the issue for hours. However, no luck. Since I don't really know how else to describe what I'm dealing with, I'll leave a picture which shows exactly what happens when I try to connect to the server.

[Linked Image from]

I found a couple answered threads which had reflected on the same problem (sort of), but either I'm doing something wrong or I don't understand what needs to be done.

The most common reason for seeing "SSL certificate verify failed" is that you are trying to connect to a server that is using an invalid certificate. You can try changing the SSL settings in the Options/Connect/Options/SSL dialog to "Display invalid certificates for approval" to see if that makes a difference.

In my case, it doesn't, the problem remains. I tried relogging several times, but it's persistently (although very kindly) telling me to back off and eventually give up.

Thanks for your bug report. That is because the servers are using STS whose purpose is to prevent man-in-the-middle attacks by requiring a stricter connection policy to a specific address and port and validation of the certificate. You will need to contact the administrators to ask them to either remove the stricter requirement of STS or to fix their certificate. That said, if they remove the requirement for STS on their servers, the STS protocol requires clients to continue using the saved STS details until they expire. You would need to use the clear history option to delete your SSL and STS cache in mIRC to be able to connect to the servers with an invalid certificate once they have removed STS support.

If I got it right, I basically have no option other than waiting for an administrator (of the server) to try one of those in order to make the server available again. I've searched through options and couldn't find anything of help or assistance, leaving me completely helpless.
I reinstalled mIRC, didn't work. I made sure to remove both SSL and STS cache (upon exit), still no satisfying result.

I'm sincerely hoping to get some answers which could fix the problem in the long term or get me to understand what is going on at least.
Apologies in advance if my questions/conclusions tend to sound stupid, but I'm just clueless right now. Thanks! smile