mIRC Home    About    Download    Register    News    Help

Print Thread
#270954 31/10/22 09:58 AM
Joined: Sep 2005
Posts: 104
Vogon poet
OP Offline
Vogon poet
Joined: Sep 2005
Posts: 104
Just open mIRC and Script Editor (but not on the Desktop option).
Use full screen mode (F11) and //echo -s * $fullscreen

I received 0. I own one monitor.

Regards.


when no one watching us
we are invisible
Joined: Jan 2004
Posts: 1,949
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,949
When in F11 mode I am not able to get $fullscreen to report anything except 0, regardless of anything related to the script editor or desktop windows.

I own more than 1 monitor, but only 1 is plugged in

I'm curious if when you do receive a '1', if you are seeing an option in the upper-left context menu of the main window to toggle fullscreen off, because I do not

Joined: Sep 2005
Posts: 104
Vogon poet
OP Offline
Vogon poet
Joined: Sep 2005
Posts: 104
I see the option. In addition, there is a "bird" in the menu that the function is enabled. But $fullscreen reports 0.
I think the problem also occurs with @windows with specific flags open.
I have several in the toolbar. If i use /toolbar -r function $fullscreen reports 1.
I haven't fully figured out the issue yet.


when no one watching us
we are invisible
Joined: Dec 2002
Posts: 5,230
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,230
Thanks, I was able to reproduce this here. In my case, it was due to an OSD window for caps/numlock keys that had some odd properties. I have made a change that skips windows like this. Let's see how it works out in the next beta.

Joined: Sep 2005
Posts: 104
Vogon poet
OP Offline
Vogon poet
Joined: Sep 2005
Posts: 104
Fixed in latest beta. Thanks.


when no one watching us
we are invisible

Link Copied to Clipboard