mIRC Home    About    Download    Register    News    Help

Print Thread
Joined: Jan 2004
Posts: 1,997
maroon Offline OP
Hoopy frood
OP Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,997
$wrap 'biptw' parm without 'w' switch

When not using the 'biptw' parm, $wrap is wrapping the text to the next line, as is the historical behavior. However, when using the optional 'biptw' parm without mentioning the 'w' switch, the default behavior changes to chopping a word rather than wrapping it to the next line. Since the 'biptw' parm is optional, it's not expected that it would change the default behavior of 'w' unless w0 is used to 'set the option' differently than the default.

If this has been existing long enough to be part of the design, then perhaps the documentation should clarify that using the biptw parm requires using 'w' or 'w1' to continue the default behavior.

i.e. the default without using the optional parm appears to be b0i0p0t0w1, but setting any of the other 4 options also changes the 'w' setting to w0, and same for this example using the non-existant 'z' switch.

//var -s %i 1, %a the quick brown fox jumps over a lazy dog , %font Consolas , %fontsize 21, %width 280 | while (%i isnum 1-2) { echo 3 -a biptw parm skip: $wrap(%a,%font,%fontsize,%width,%i) | echo 4 -a biptw parm used: $wrap(%a,%font,%fontsize,%width,z,%i) | inc %i }

skip biptw parm::: the quick brown fox
use z switch only: the quick brown fox jum
skip biptw parm::: jumps over a lazy dog
use z switch only: ps over a lazy dog

Joined: Dec 2002
Posts: 5,244
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,244
Thanks for your bug report. This is the intended behaviour. When the "w" option was added, it was set to off by default for the simple reason that using w means turn it on, and not using it means don't turn it on.


Link Copied to Clipboard