mIRC Home    About    Download    Register    News    Help

Print Thread
Not able to receive files #270502 13/07/22 03:35 AM
Joined: Jul 2022
Posts: 2
S
SeaShells Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
S
Joined: Jul 2022
Posts: 2
Hi there!
This is my first post so hope I'm in the right place.

My problem started after the latest update after which I have not been able to receive files -- I'm told to check my settings but cannot for the life of me think of what the issue is so I'm hoping for some help. I'm pretty new to using mIRC though I've never had any issues before. Basically what I'm saying that I need step by step instructions if possible.

Anyways, I hope someone can help me with this smile
SS


Re: Not able to receive files [Re: SeaShells] #270506 14/07/22 06:57 PM
Joined: Jan 2004
Posts: 1,805
maroon Offline
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,805
I'm not sure what's causing this, so can't list any steps to fix it. Normally DCC problems affect the ability to send files, so 1 thing to do would be to make sure the problem isn't really that the other person can't send.

One thing that can affect the ability to receive files is PASSIVE DCC. In order for someone to send, they must use ports forwarded in the router. Normally, DCC SEND uses ports forwarded by the sender, but with PASSIVE DCC it uses the receiver's forwarded ports instead. So, if your own ports are no longer forwarded, then the other person's sends can't use your forwarded ports. You didn't say whether or not you can send too.

You didn't list the symptoms. Is there just no response, or do you see the incoming file that just stalls-out before eventually failing.

You might try coming to #mirc on libera.chat or efnet and see if someone can see if they can figure something out.

Another thing that could cause the problem is that a script can interfere with this, so try temporarily disabling events with

/REMOTE OFF

then see if it works. But then be sure to turn back on with: /REMOTE ON

Another thing that can cause the problem is if you have them in your ignore list so that you don't see either the NOTICE or CTCP message associated with a DCC SEND, so see if they're showing up:

/ignore -l

Re: Not able to receive files [Re: maroon] #270522 20/07/22 02:22 AM
Joined: Jul 2022
Posts: 2
S
SeaShells Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
S
Joined: Jul 2022
Posts: 2
Thank you for your reply. I can receive notepad/text files but not any other type of files, and all I get is a notification from the sender that "I tried to send you the file, check your settings and try again - every single time. I've never had this problem until I switched to a new computer but I haven't changed any settings so it's a mystery to me. The files I cannot receive at all are all epub files and it seems to definitely be a problem on my end. I'll check out your suggestions and keep asking around but I'm getting pretty desperate tbh.

SS smile

Re: Not able to receive files [Re: SeaShells] #270532 20/07/22 10:15 PM
Joined: Jan 2004
Posts: 1,805
maroon Offline
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,805
Thanks for your reply. You are now describing the problem completely differently than before. First it was that you couldn't receive any files at all, now the problem is that you cannot receive .epub files.

This is the default setting, so you simply need to change it. You ended up at the default state either by something you did or didn't do while installing the newer version of mIRC, or else something that occasionally happens with mIRC is that mirc.ini gets trashed so it recreates mirc.ini from scratch containing the default settings.

In options/dcc/ignore the settings are either to have a list of *.filetypes which are the only ones accepted, or a different list of *.filetypes which are the only ones rejected, or a 3rd setting that disables the ignore settings. You can also check by seeing if this the answer is $true to pasting this in any editbox:

//echo -a $dccignore(file.epub)

My guess is that you have the setting which only accepts a list of filetypes, and these are not in the list.

Assuming the settings shows to be "accept only", the fix is to simply type *.epub in the input box then click 'add' then 'ok'.
If the setting is "ignore only" and *.epub is on the list, simply find the offending file from the ignore list then click "delete"

If this isn't the problem, you could have visited the channel as I mentioned earlier and saved yourself the trouble of these past few days



Last edited by maroon; 20/07/22 10:16 PM.