mIRC Home    About    Download    Register    News    Help

Print Thread
Not detecting disconnects #267804 03/10/20 09:03 PM
Joined: Oct 2014
Posts: 36
O
Orobas Offline OP
Ameglian cow
OP Offline
Ameglian cow
O
Joined: Oct 2014
Posts: 36
Got a bizarre one with 7.63 Mirc...

Have it installed as a portable installation on a folder x2 on my desktop.. one for my main mirc chat and one for my bot.

I have recently had the weirdest thing occuring with my bot folder.. the bot can ping out or lose connection but it still shows on its screen that it is online when it is not.. for some reason it is not picking up the fact it has disconnected and will happily sit there if i am not in attendace for a good several hours before it finally realises..

Is this something on 7.63?

The only other unusual thing i have done out of the ordinary was upgrade my cpu and motherboard and plug my m.2 with the os and everything back in and carried on as normal. I did NOT do a new install.

Here is the weird one.. my main chat client however.. does see when it pings out or disconnects and will reconnect... both are installed on the desktop to seperate folders as portable!

Any ideas ?

Re: Not detecting disconnects [Re: Orobas] #267805 04/10/20 02:41 AM
Joined: Jan 2004
Posts: 1,409
maroon Offline
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,409
Is there a typical time connected to server when this happens?
The default setting for options/connect/options is to have a check next to "check connection time out", is that checked?
Is this issue affected by whether you connect to the network using the same vs 2 different servers?
Is this issue affected by whether the bot folder is the first/last one connected to the network?

Re: Not detecting disconnects [Re: Orobas] #267806 04/10/20 09:10 AM
Joined: Dec 2002
Posts: 4,829
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,829
This is a commonly asked question, so it is not specific to any version. It is also a commonly asked question in socket programming in general, eg. see stackoverflow.

mIRC uses several methods to detect connection timeouts, eg. socket keepalives, pings to the server (the "Check for connection time out" option, which is enabled by default), and so on.

If it is still not detecting a connection error, this means that something else is going on, eg. there is an issue with your router, Windows, the server, ZNC, firewall, that particular connection, etc.

If you use the "/debug @debug" command, this will show incoming/outgoing server messages in a @debug window. You can use this to monitor the "Check for connection time out" which will send a ping to the server if there has been no activity for a few minutes.

Re: Not detecting disconnects [Re: Khaled] #267807 04/10/20 09:59 AM
Joined: Oct 2014
Posts: 36
O
Orobas Offline OP
Ameglian cow
OP Offline
Ameglian cow
O
Joined: Oct 2014
Posts: 36
I have just enabled the "check connection time out" on the bot mirc.. this is not enabled on my main mirc.
I have also now set /debug @debug to check back also the next time it ocurs.

Other items of note.. the bot is always the 2nd connection to the network,, my main chat mirc is always the first to open and connect when i do this.

I am also testing with a ping/pong script to see the server replies.. and it appears the bot hovers around 7mins between pings.
We're on unrealircd 5.0.6.

I'll run with these items for the next error and report back