mIRC Home    About    Download    Register    News    Help

Print Thread
RAWS 900+903 are missing on success #267333 03/06/20 07:25 PM
Joined: Oct 2017
Posts: 23
D
DooMaster Offline OP
Ameglian cow
OP Offline
Ameglian cow
D
Joined: Oct 2017
Posts: 23
Hello, Greetings from Dachau

When I'm connecting to a server especially on UnrealIRCD (5.0.5.1) and using SASL /CAP I am not getting a SASL authentication successful message on active, neither too the You are now logged in as <account>.

Both of them should be displayed on the active window.

Debug:

Code
-> irc.network.com CAP LS 302
-> irc.network.com NICK mynickname
-> irc.network.com USER mynickname 0 * :...
<- :irc.network.com CAP * LS :unrealircd.org/link-security=2 unrealircd.org/plaintext-policy=user=warn,oper=deny,server=deny sts=port=6697,duration=15552000 extended-join chghost cap-notify userhost-in-names multi-prefix away-notify sasl=AUTHCOOKIE,PLAIN tls account-notify message-tags batch account-tag server-time echo-message labeled-response
-> irc.network.com CAP REQ :extended-join
-> irc.network.com CAP REQ :chghost
-> irc.network.com CAP REQ :userhost-in-names
-> irc.network.com CAP REQ :multi-prefix
-> irc.network.com CAP REQ :away-notify
-> irc.network.com CAP REQ :sasl
-> irc.network.com CAP REQ :account-notify
-> irc.network.com CAP REQ :message-tags
-> irc.network.com CAP REQ :batch
-> irc.network.com CAP REQ :account-tag
-> irc.network.com CAP REQ :server-time
<- :irc.network.com CAP mynickname ACK :extended-join 
<- :irc.network.com CAP mynickname ACK :chghost 
<- :irc.network.com CAP mynickname ACK :userhost-in-names 
<- :irc.network.com CAP mynickname ACK :multi-prefix 
<- :irc.network.com CAP mynickname ACK :away-notify 
<- :irc.network.com CAP mynickname ACK :sasl 
-> irc.network.com AUTHENTICATE PLAIN
<- :irc.network.com CAP mynickname ACK :account-notify 
<- :irc.network.com CAP mynickname ACK :message-tags 
<- :irc.network.com CAP mynickname ACK :batch 
<- :irc.network.com CAP mynickname ACK :account-tag 
<- :irc.network.com CAP mynickname ACK :server-time 
<- AUTHENTICATE +
-> irc.network.com AUTHENTICATE BWRpaXJjAGFkaWlyYwB3ZXN0b3I0
<- :irc.network.com 900 mynickname mynickname!ident@hostname mynickname :You are now logged in as mynickname.
-> irc.network.com CAP LIST
-> irc.network.com CAP END
<- :irc.network.com 903 mynickname :SASL authentication successful
<- :irc.network.com CAP mynickname LIST :extended-join chghost cap-notify userhost-in-names multi-prefix away-notify sasl=AUTHCOOKIE,PLAIN account-notify message-tags batch account-tag server-time
<- :irc.network.com 001 mynickname :Welcome to the Network IRC Network mynickname!ident@hostname


Re: RAWS 900+903 are missing on success [Re: DooMaster] #267334 04/06/20 08:27 AM
Joined: Dec 2002
Posts: 4,736
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,736
Thanks for your bug report. It looks like this can happen if your remotes are disabled, ie. /remote off. If I enable remotes, it displays the logon/authentication as expected. This has been fixed for the next version.