I am experiencing an issue that seems to be similar to this one.

It happens when you specify a log file for the status window to log to after having turned logging off and on again via the System Menu.

It seems I have been experiencing this issue since May 2017, but only found this out recently, as I wanted to look something up in my status logs.

So, I have one server added in the server list, and all the other servers are specified via /server <address> commands. I run an alias that runs /server <groupname> for the one server in the list, and /server <address> for all others. I tried to be clever about this and introduce delays (20 seconds) via timers in between the /server commands to give mIRC time to figure out the network name and move the status log to the appropriate network folder before moving on to the next server (as I thought mIRC might be getting confused or something), but to no avail.

This seems to have never been an issue before May 2017. Thinking about it, this issue started to appear with the 7.48 or 7.49 update, as according to my status logs April 2017 was the last log to have a full log from the 1st of April to the 30th, and starting from May 2017 the status logs are either incomplete or are just a total mess.

But then it hit me. Its actually not the 7.48 or 7.49 versions that caused this issue for me.

At some point in time (probably in May 2017 whistle) I turned off and on the status logging via the System Menu for one network several times, because I wanted to hash passwords via /mkpasswd (an inspircd command) and did not want it logged. Upon turning logging for the status window back on, mIRC asks for a file to start logging to again.

Anyway, I closed mIRC, went in mirc.ini and removed the one status log line I could find:

I removed this to restore the default logging, and now all seems well again. Restarted mIRC a couple of times, and I cannot reproduce it anymore. Before removing that line I could reproduce this issue every single time.