mIRC Home    About    Download    Register    News    Help

Print Thread
Problem with scripted server connection and SASL #260775 14/06/17 03:16 PM
Joined: Jul 2005
Posts: 5
G
GiGaHeRz Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
G
Joined: Jul 2005
Posts: 5
Hello,

First of all, thanks for still maintaining the program I have used for the longest time (I have used mIRC continuously since I got dialup in the late 90s).

I just updated to 7.49, and I can't seem to reliably log in to the Freenode or EsperNet networks anymore.

I have used for a long time a small script to automatically use /server -m to connect me to my usual servers.

In 7.48, I was able to configure a server to use CAP SASL, and the "/server -m irc.esper.net" would properly use the right authentication method, and send the proper user/password for the login.

However, in 7.49, this is no longer true. When I run the command, the protocol dump looks like:

Code:
-> irc.esper.net CAP LS 302
-> irc.esper.net PASS LM2?LM1?gigaherz:PASSWORD_HERE_CENSORED
-> irc.esper.net NICK gigaherz
-> irc.esper.net USER giga 0 * :the one
<- :ranger.esper.net NOTICE * :*** Looking up your hostname...
<- :ranger.esper.net NOTICE * :*** Checking Ident
<- :ranger.esper.net NOTICE * :*** Found your hostname
<- :ranger.esper.net NOTICE * :*** Got Ident response
<- :ranger.esper.net CAP * LS :account-notify away-notify cap-notify chghost extended-join multi-prefix sasl tls userhost-in-names
-> irc.esper.net CAP REQ :account-notify
-> irc.esper.net CAP REQ :away-notify
-> irc.esper.net CAP REQ :chghost
-> irc.esper.net CAP REQ :extended-join
-> irc.esper.net CAP REQ :multi-prefix
-> irc.esper.net CAP REQ :userhost-in-names
<- PING :238DF2F0
-> irc.esper.net PONG :238DF2F0
<- :ranger.esper.net CAP gigaherz ACK :account-notify
<- :ranger.esper.net CAP gigaherz ACK :away-notify
<- :ranger.esper.net CAP gigaherz ACK :chghost
<- :ranger.esper.net CAP gigaherz ACK :extended-join
<- :ranger.esper.net CAP gigaherz ACK :multi-prefix
<- :ranger.esper.net CAP gigaherz ACK :userhost-in-names
-> irc.esper.net CAP LIST
-> irc.esper.net CAP END
<- :ranger.esper.net CAP gigaherz LIST :account-notify away-notify chghost extended-join multi-prefix userhost-in-names
<- :ranger.esper.net 001 gigaherz :Welcome to the EsperNet Internet Relay Chat Network gigaherz
-> ranger.esper.net USERHOST gigaherz
<- :ranger.esper.net 002 gigaherz :Your host is ranger.esper.net[168.235.75.5/6697], running version charybdis-3.5.3

... continues ...



It seems that mirc 7.49 has troubles applying the right login settings when using the /server command without any password parameter, and I really hope that this is not by design, because it breaks one of my my most essential scripts (I really do not want to embed the plaintext password in a script file).

Re: Problem with scripted server connection and SASL [Re: GiGaHeRz] #260776 14/06/17 04:41 PM
Joined: Mar 2008
Posts: 90
B
BhaaL Offline
Babel fish
Offline
Babel fish
B
Joined: Mar 2008
Posts: 90
I wasn't sure if this would work correctly for me when SASL support was added, so I cleared the server list (because I never really used it for anything) and only put my usual servers in there (using named groups such as "FreeNode" etc.) - including the SASL login data.
Afterwards I modified my connect script (which does /server -m for my common servers, just like yours) to use the Group Name (ie. /server -m FreeNode) instead of the server address (ie. /server -m irc.freenode.net)

And that has worked for me ever since, even with latest 7.49; but YMMV. It might be an alternative to try out, since its a one-time only configuration thing.

Although, this doesn't necessarily mean that your method (with the server address) is supposed to be working but is broken, or is not supposed to work by design. Only Khaled can answer that.

Re: Problem with scripted server connection and SASL [Re: GiGaHeRz] #260781 15/06/17 08:48 AM
Joined: Dec 2002
Posts: 4,832
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,832
Thanks for your bug report. This sounds like it is related to this issue. If you open the Options dialog, Servers section, select the entry for that server and click "Edit", type in the server password, press "OK", and click "Select" and then connect to the server, does it work?

Re: Problem with scripted server connection and SASL [Re: Khaled] #260805 19/06/17 07:50 PM
Joined: Jul 2005
Posts: 5
G
GiGaHeRz Offline OP
Nutrimatic drinks dispenser
OP Offline
Nutrimatic drinks dispenser
G
Joined: Jul 2005
Posts: 5
Originally Posted By: BhaaL
I wasn't sure if this would work correctly for me when SASL support was added, so I cleared the server list (because I never really used it for anything) and only put my usual servers in there (using named groups such as "FreeNode" etc.) - including the SASL login data.
Afterwards I modified my connect script (which does /server -m for my common servers, just like yours) to use the Group Name (ie. /server -m FreeNode) instead of the server address (ie. /server -m irc.freenode.net)

And that has worked for me ever since, even with latest 7.49; but YMMV. It might be an alternative to try out, since its a one-time only configuration thing.

Although, this doesn't necessarily mean that your method (with the server address) is supposed to be working but is broken, or is not supposed to work by design. Only Khaled can answer that.


I will try that as a workaround, thanks.

Originally Posted By: Khaled
Thanks for your bug report. This sounds like it is related to this issue. If you open the Options dialog, Servers section, select the entry for that server and click "Edit", type in the server password, press "OK", and click "Select" and then connect to the server, does it work?


If I connect to the server using the dialog, it works fine every time. It's only when I use the "/server" command that it seems to fail.

Note that this is SASL I'm talking about, not just a normal server password.

Re: Problem with scripted server connection and SASL [Re: GiGaHeRz] #260822 22/06/17 06:17 PM
Joined: Dec 2002
Posts: 4,832
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 4,832
Unfortunately, I am not sure what to suggest. I tested this in v7.49:

1. Edited the Freenode server entry, selected method SASL and typed in the SASL password, pressed OK to save the server.
2. Clicked Select button.
3. Pressed OK to close the Options dialog.

I then tried connecting to the server using both "/server" and "/server -m" and both connected and logged on correctly.

If you follow the above steps in v7.49, does it not work for you?