mIRC Home    About    Download    Register    News    Help

Print Thread
issue with ident under 7.1 #224245 07/08/10 10:50 AM
Joined: Mar 2004
Posts: 526
HorseC Offline OP
Fjord artisan
OP Offline
Fjord artisan
Joined: Mar 2004
Posts: 526
Hi all,

Subject says it all here are the particulars:


ident fails (for me) under 7.1

ident works (for me) under 6.35

both running with SAME scripts. (how you ask?)

(running each version from a seperate directory,
with a mirc.ini in each)

(above was done by doing full copy of 6.35 directory
(and subs) to new directory before doing install
of 7.1 (released version)

Here is where it gets weird...

If i bring up 6.35 version FIRST. and the ident works...

If i THEN bring up 7.1 (from different directory
while 6.35 is running) then ident works!

However, If I ONLY bring up 7.1 (no 6.35 running)
then ident fails.

This testing was done on two different networks
(DALnet and EFNET) with the same results.

more info that may help:

on 7.1
under ports:
UPnP support... NONE of these are checked
(nothing enabled)

under identd:
enabled identd server checked
port 113
show identd requests IS checked
enabled only when connecting NOT checked.
Use ID from email address NOT checked

no proxy settings enabled

local settings.
on connect get:
Host name checked.
lookup method normal checked.

Under 6.35

All options that apply (ie identd and proxy)
are the same..
port settings are the same, since there is no
UPnP support settings in that version. nothing set

os: windows xp sp1

Not sure what else I can provide. Let me know what else
is needed. I will try to provide it.

Thanks.

HorseC

Re: issue with ident under 7.1 [Re: HorseC] #224247 07/08/10 12:13 PM
Joined: Dec 2002
Posts: 5,016
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,016
Is this a recent issue or has it always been the case? This usually indicates that your copy of mIRC v7.1 is being blocked from being a "server" either by Windows or by anti-virus/firewall software. You would need to ensure that the identd server in mIRC is being allowed to listen for incoming connections.

Re: issue with ident under 7.1 [Re: Khaled] #224249 07/08/10 12:17 PM
Joined: Mar 2004
Posts: 526
HorseC Offline OP
Fjord artisan
OP Offline
Fjord artisan
Joined: Mar 2004
Posts: 526
thanks K. checking this now.. will keep you informed.

Re: issue with ident under 7.1 [Re: HorseC] #226044 16/09/10 05:56 PM
Joined: Jun 2004
Posts: 139
N
Ninko Offline
Vogon poet
Offline
Vogon poet
N
Joined: Jun 2004
Posts: 139
Hi there,
My Identd with mIRC v7.1 was working well with upnp but today has stopped working, it has been ever since my computer installed Microsoft's monthly updates.

I have 3 systems, 2 are Windows XP SP3 and nither will Identd after the updates, but the 3rd Windows Vista SP2 still works fine after the updates.

If you need further info let me know, such as which updates were installed etc.

Thanks


Ninko

Re: issue with ident under 7.1 [Re: Khaled] #226048 16/09/10 09:49 PM
Joined: Mar 2004
Posts: 526
HorseC Offline OP
Fjord artisan
OP Offline
Fjord artisan
Joined: Mar 2004
Posts: 526
K,

Just an FYI for you.. my problem turned out to be the pctools firewall, it defaults to 'stelth' mode which blocks ident requests. So each time I upgade mIRC or any other software that requires ident ok, then i have to update that programs action in pctools firewall. Though you might want to add this to your list of possible resolutions to ident problems.

as ever,

HorseC


Help others! It makes the world a better place, Makes you feel good, and makes you Healthy!
Re: issue with ident under 7.1 [Re: HorseC] #226049 16/09/10 10:10 PM
Joined: Aug 2010
Posts: 134
T
Thels Offline
Vogon poet
Offline
Vogon poet
T
Joined: Aug 2010
Posts: 134
Originally Posted By: HorseC
If i THEN bring up 7.1 (from different directory
while 6.35 is running) then ident works!


The IDENT server is actually separate from the rest of the communication. If you don't enable "Only when connecting" (or even when you do, but two connections are close to each other), then the mIRC 6.35 client acts as an IDENT server for all IRC connections you make, including the ones you make from other computers that are connected through the same router, and therefor have the same global IP.

That should explain why your IDENT did work when both 6.35 and 7.1 were running.


Learning something new every day.
Re: issue with ident under 7.1 [Re: HorseC] #226062 17/09/10 02:09 PM
Joined: Jun 2004
Posts: 139
N
Ninko Offline
Vogon poet
Offline
Vogon poet
N
Joined: Jun 2004
Posts: 139
Originally Posted By: HorseC
K,

Just an FYI for you.. my problem turned out to be the pctools firewall, it defaults to 'stelth' mode which blocks ident requests. So each time I upgade mIRC or any other software that requires ident ok, then i have to update that programs action in pctools firewall. Though you might want to add this to your list of possible resolutions to ident problems.

as ever,

HorseC


Hi HorseC,
I've already made sure that access through my firewall has been refreshed.

Thanks


Ninko

Re: issue with ident under 7.1 [Re: Ninko] #226077 18/09/10 04:15 AM
Joined: Jun 2004
Posts: 139
N
Ninko Offline
Vogon poet
Offline
Vogon poet
N
Joined: Jun 2004
Posts: 139
Hi Khaled,
Any suggestions regarding my problem, seems to be different to HorseC.

Thanks


Ninko

Re: issue with ident under 7.1 [Re: Ninko] #226109 19/09/10 02:48 PM
Joined: Dec 2002
Posts: 5,016
Khaled Offline
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,016
Since the identd in mIRC was working before and only stopped after you updated your system, this means that something on your system has changed and is now blocking the identd in mIRC.

You will need to check your anti-virus and firewall settings.

If the UPnP identd option is enabled in mIRC, you will need to make sure that UPnP is working correctly on your system.

If you are not using UPnP, you will need to make sure that your router is correctly configured to allow incoming connections on port 113 and that your anti-virus and firewall software are also allowing those connections.

Re: issue with ident under 7.1 [Re: Khaled] #226782 14/10/10 07:45 PM
Joined: Jun 2004
Posts: 139
N
Ninko Offline
Vogon poet
Offline
Vogon poet
N
Joined: Jun 2004
Posts: 139
Hi Khaled,
The problem has appeared to have sorted its self out. No idea what went wrong there.

Thanks for your help though!


Ninko