mIRC Home    About    Download    Register    News    Help

Print Thread
Joined: Oct 2003
Posts: 18
M
Pikka bird
OP Offline
Pikka bird
M
Joined: Oct 2003
Posts: 18
Line wrapping is now broken in mIRC when dealing with lines encoded in UTF-8..

Steps to reproduce: Clean install of mIRC 6.32 on a Western European Windows. Enabled multibyte display in the options and set UTF-8 to display & encode in the channel settings. Copy & pasted a line of text from the Japanese Wikipedia. As long as the text fits in one line, it looks ok:



But when I make the window a bit smaller:



Expected result: the line should wrap without breaking ;-) It works fine in 6.31.

Other info: toggling Multibyte display doesn't change anything.

Joined: May 2006
Posts: 93
Babel fish
Offline
Babel fish
Joined: May 2006
Posts: 93
Just installed 6.32 and got the same problem, it fails where 6.31 worked.

As in 6.31 changing the width of the window alter the visualization of the characters but there is still no way to have all them displayed correctly and even if sometimes the characters on the last line are displayed correctly the overall situation is worse (whereas in 6.31 it usually worked for the first few lines and then it fails on the others).
The "Fixed multi-byte text-wrapping display issues." doesn't seem to work.

If you need some screenshots and/or more infos let me know, I'm running win xp sp2.

If you want to test it you can find here http://dpaste.com/52723/ 3 lines with the hiragana, katakana, greek and coptic characters that are displayed correctly on 6.31 and as a list of "", squares and some other characters in 6.32.

Last edited by Taggnostr; 26/05/08 06:32 AM.
Joined: Jul 2007
Posts: 21
Ameglian cow
Offline
Ameglian cow
Joined: Jul 2007
Posts: 21
I advantage of this topic to report another UTF-8 bug.
Today I noticed that if I write an Asiatic character and add the char the conversion not appear... like in the image (I use a my own skin engine)

Last edited by Jacksoft; 31/05/08 11:29 PM.
Joined: Dec 2002
Posts: 2,962
S
Hoopy frood
Offline
Hoopy frood
S
Joined: Dec 2002
Posts: 2,962
That's because the ANSI encoding of those characters is invalid UTF-8, so when mIRC sees them it assumes that the rest of the line isn't UTF-8 either. To fix this you should use the $utfencode() identifier around the guillemets (the characters).


Spelling mistakes, grammatical errors, and stupid comments are intentional.
Joined: Oct 2003
Posts: 3,918
A
Hoopy frood
Offline
Hoopy frood
A
Joined: Oct 2003
Posts: 3,918
$utfencode is not necessarily a fix, see the original posting of this issue here:

http://forums.mirc.com/ubbthreads.php?ubb=showflat&Number=196819

There is no workaround to this issue, currently.


- argv[0] on EFnet #mIRC
- "Life is a pointer to an integer without a cast"
Joined: Dec 2002
Posts: 5,244
Hoopy frood
Offline
Hoopy frood
Joined: Dec 2002
Posts: 5,244
Thanks this has been fixed - I plan to release a new version with this issue fixed as soon as the handful of other outstanding issues are resolved.


Link Copied to Clipboard