How about an option in the sound options to disable the 'beep' you get once you've typed past the buffer length? For one reason or another, this never worked for me, regardless of sound settings. But since the upgrade to 6.21, it all of a sudden works.

I've created a script to work around the buffer limit, so the reminder is not needed. The only way to turn it off is to turn off all sounds. But.. then none of the highlights set to beep when triggered work.

I know this option really wouldn't be needed for the general mass of mIRC users, but for the few of us that do DnD and other such roleplay over irc (and for the many that use my cut script) this option would really be helpful.