var's syntax is
The fact that
sometimes works is an artifact, from what I understand. Therefore code should not depend on that form.
I, personally, wouldn't be averse to having set and var's syntax consolidated to one or the other form. Preferably with '=' it's just more aesthetically pleasing, imho
P.S. I am pretty certain your point has been raised several times previously.