mIRC Home    About    Download    Register    News    Help

Print Thread
Auto Connect on Startup #116154 02/04/05 11:58 PM
Joined: Apr 2005
Posts: 2
X
xscorpion Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
X
Joined: Apr 2005
Posts: 2
When I launch mirc it auto connects to a server and then connects to a channel. How do I disable this function?

Re: Auto Connect on Startup #116155 03/04/05 12:04 AM
Joined: Feb 2005
Posts: 194
A
alhammer Offline
Vogon poet
Offline
Vogon poet
A
Joined: Feb 2005
Posts: 194
Hey. Go to the options. (ALT-O) Find the "Options" submenu under the Connect menu. Uncheck the "Connect on Startup" box. As far as the autojoing a channel, that is probably the server. Many servers have a default channel, which you will automatically join when you connect. If that's not the case, check all of your remotes. I hope this helps. laugh


"God sometimes puts us in the dark for us to see the light"
Re: Auto Connect on Startup #116156 03/04/05 12:09 AM
Joined: Jun 2003
Posts: 5,024
M
Mentality Offline
Hoopy frood
Offline
Hoopy frood
M
Joined: Jun 2003
Posts: 5,024
Type /!remote off to prevent any scripts running (though this won't prevent STARTUP scripts because you can't type it before mIRC starts up).

If you have a script, then I would say it's actually that forcing you to join a channel - check out the channel name and topic - if it's related to the script, then it will be the script, if it's something else, then it may well be a network channel. Also, if you type /!remote off and still join then it's the network.

Don't install scripts if you don't know what they do, or how to control them.

Regards,


Mentality/Chris
Re: Auto Connect on Startup #116157 03/04/05 12:22 AM
Joined: Dec 2002
Posts: 3,547
S
SladeKraven Offline
Hoopy frood
Offline
Hoopy frood
S
Joined: Dec 2002
Posts: 3,547
If the channel can't be found in the mIRC Script and you're not being pulled into the channel by an IRCop (if it joins you to the same channel on different networks).

They could also try /!perform off.

Although the On Start event could be the reason it connects to a server, they probably havethe channel to join in the perform box. smile

Re: Auto Connect on Startup #116158 03/04/05 12:33 AM
Joined: Apr 2005
Posts: 2
X
xscorpion Offline OP
Bowl of petunias
OP Offline
Bowl of petunias
X
Joined: Apr 2005
Posts: 2
thanks for the post. none of them work. tried /!perform off opened mirc again did samething. tried /!remote off then open again then nothing started.

Re: Auto Connect on Startup #116159 03/04/05 05:54 PM
Joined: Feb 2005
Posts: 194
A
alhammer Offline
Vogon poet
Offline
Vogon poet
A
Joined: Feb 2005
Posts: 194
Did you read the MOTD or go to the HelpDesk channel and ask if there was a default-autojoin channel? Or do you mean it still connects on startup? If so, did you check in your options like I suggested?

Last edited by alhammer; 03/04/05 05:56 PM.

"God sometimes puts us in the dark for us to see the light"