I had this problem once, but i don't remember exactely how i fixed it. Go to Windows' Control Panel -> "Regional and Language Options" and see "Languages" and "Advanced" tabs for any unusual options checked, like East Asian languages or right-to-left support. You can also try to turn off "Advanced text services" ("Languages" tab -> "Details" -> "Advanced" tab) and see if it makes any change. Good luck.