I agree with Watchdog, xp's firewall dislikes having another one running and that may be the cause of your problem. Disable one of them and see if that fixes it.

You can find a tutorial on xp's firewall at http://toidyman.net/xp-dcc/

Note that your firewall should be allowing mIRC access to begin with, and also ports 6660-6669,7000-7001 and 113 for identd as well as some within the 1024-5000 range if you want to be able to dccsend (then put the ones you chose in mirc's dcc options)

Just as an FYI, in file/options/connect/firewall, leave it set to none. that doesnt apply to the type of firewall you are running.

ParaBrat @#mIRCAide DALnet