Westor - Went with Khaled's reply first... which seems to have narrowed down the problem as a script-bug, and not a bug in mIRC itself. I never did get around to any extensive testing on this. Attributed it to a fluke on version 7.41, and only when it reoccurred on version 7.43 I considered it something that might hint at a bug. Moreso because on every upgrade of mIRC it ran without any issues.

I just installed mIRC 7.43 in a completely separate folder instead of upgrading the existing version (I didn't install it as a portable application, just a completely clean folder). mIRC starts up fine and dandy. Connects properly, and can join channels normally.

Okay, lets see here... Copied all of the INI files, added MRC scripts, DAT file and a heap of folders (sounds, logs, data) over. Started mIRC... it hung itself. Removed all the copied stuff and tried, mIRC started happily.

I just copied all of the INI files over, and tried. mIRC started properly. So it doesn't seem to be a problem in mIRC at all, but rather in something I added in either the script or an add-on.

A couple of mrc-script files, and a DLL file... Copied those, and tried. No problem. Starting normally.

Got a folder 'data', which only contains a settings.ini. No real idea where that one came from, but copied it over. Contents of the INI file make me doubt severely that it is the cause, but still want to exclude it from my suspect list. mIRC still starts normally.

In which case I'm left with one folder that I did not yet copy... GTSDLL to announce what mediaplayer/winamp is doing... I haven't used mIRC in a while, so that might also be outdated. Looked in the changes.txt file, and found the version I apparently have is Which according to http://www.gts-stuff.com/index.php/topic,1664.0.html is the last one...

Copied it over, and tried... No clue what the heck changed, but mIRC just started normally too... So it's not that either. Tho I did notice GTSDLL isn't loaded in mIRC 7.43. Whereas it IS loaded in version 7.38.

So then I ran through the ini files, and found the rfiles-section in mirc.ini which points at the gtsdll.ini file. This section differs in the mirc.ini files between the two versions tho. Apparently it dumps everything it can't find out on starting.

There's two lines in the original 7.38 version that are not in the copy (7.43) anymore:


These lines were probably deleted on my first start of mIRC, where I hadn't copied the MRC script, nor had I copied GTSDLL.

I recall (vaguely) the opme script was included to use a backdoor to talk to a bot as a non-admin user, and push the bot into giving you operator status based on a password held in the bot-config. So you could gain channel-ops even if your ident wasn't recognized by any of the bots in the channel. Not using that anymore, heck some of the bots it was used with don't even exist anymore.

Still added the extra line to include opme.mrc to the mirc.ini file, and kicked off mIRC 7.43. And it hung itself. Completely.

Swapped that line out with the GTSDLL bit to see if that one worked fine, started mIRC, and it works normally. So the culprit is the opme.mrc script that doesn't cause a hang with version 7.38, but does hang mIRC completely with version 7.43. Guess we can scrap this one as a bug, and more or less contribute it to some shoddy 3rd party coding.


I reject your reality, and substitute my own - Adam Savage