Originally Posted By: 5618
Twitch: shouldn't the second-to-last line read
if ((!$hget(%s,read)) && (%t != $null)) {
(because $hget(%s,read) is/needs to be $false)

I set this to $false at the start of the process, as seen in 'alias updatetopic':
hadd -m %s read $false

The first blank line the code sees in the sockread tells me we have gotten past the header data reply. so i set it to $true:
if (%t == $null) { hadd -m %s read $true }

Then I make sure this is set to $true (meaning we have gotten past the header data) and that the buffer line is not $null with this:
if (($hget(%s,read)) && (%t != $null)) {

I hope that clears up the reason why I'm checking to make sure it is $true here, other wise you would get this:

Originally Posted By: spermis
I tried this, now it at least does something, but not the correct thing. When i tried /updatetopic #blurrr it did this:
[12:42:39] * name changes topic to 'HTTP/1.1 200 OK'
[12:42:39] * name changes topic to 'Date: Thu, 12 Apr 2012 09:42:13 GMT'
[12:42:39] * name changes topic to 'Server: Apache/2.2.22 (Debian)'
[12:42:39] * name changes topic to 'X-Powered-By: PHP/5.4.0-3'
[12:42:39] * name changes topic to 'Vary: Accept-Encoding'
[12:42:41] * name changes topic to 'Content-Length: 18'
[12:42:43] * name changes topic to 'Connection: close'
[12:42:47] * name changes topic to 'Content-Type: text/html; charset=utf-8'

And just for the record, I have the same reply:

7.22 XP 912dfaee60f144853a33231688312686 ok 0 1

Lost in your digital reality.
#mIRC / #Helpdesk on DALnet.