Hm, nope, I do still have problems.

I did:

/server server1 (and waited for it to fully connect)

Identd worked fine.

Then I did:

/server server2 (wich makes it disconnect from server1 and connect to server 2)

Identd did not work

If I wait a while and do /server server2 again, Identd works.

I am going to try without Windows Firewall and after that with a different router. And maybe I'll check with an older version of Mirc as well.

Edit: without Windows firewall, it acts the same, except the server says "No Identd response" much faster. This leads me to believe that it is getting a PORT-CLOSED response on port 113 now instead of having to wait for a TIMEOUT. That means the router or firewall is not at fault for not replying to the identd. It seems mirc isn't turning on the identd-server on connect properly. Going to try with older version of mirc...

Edit2: Tried with mirc.exe from 7.14. That works fine, no matter how often I connect etc. It seems the "enable only when connecting"-option is partly broken in 7.17.

Last edited by bwuser; 21/12/10 04:25 PM.