Other than readability, I see little reason for this. When setting a variable, you don't need to evaluate anything.

/set %array $+ $me value
^ would set %arrayRiamus2 to value

You only have to evaluate when reading the value. And it's not really all that hard to read $($+(%,array,$me),2) or %array [ $+ [ $me ] ] . Sure, it's easier your way for reading the variable, but I don't think it's worth all the effort of implementing it just to make it look "pretty."

Invision Support
#Invision on irc.irchighway.net