>>2) I didnt even understand what you suggested here, maybe an example would have helped.

sorry about the ambiguity. basically, assume 32 in this example represents the number which was specified with the tokenize command. $1(text goes here) would return text. $2(text goes here) would return goes $2-3(text goes here) would return goes here, you get the idea. the token delimiter, as i stated before, uses either the default of 32, or whatever the person specified in the last /tokenize command.

oh ok that makes it clearer, unfortunitely $n identiofiers can have text attached to the end of them already, so doing this is likely to break existing scripts.
ex: //tokenize 32 a b c d | echo -a $2(x y z)
b(x y z)

>>3) Sounds good, currently i just call a second alias that calls the first one, a bit sucky but hey what can ya do.

yea, same. it's not all that bad, but i did recently run into a situation where that proved to be unsuccessful for me (i can't remember the specifics, but basically it had to do with a timer needing to call recursion, so i couldn't use $!alias to be called in the second alias being called by the timer because the timer re-evaluated aliases with $!)

?!?!? u actually called an alias !name ?
ex ALIAS !NAME { ... } ?!?!?!?

no no, i'll try to explain [argh, i lost my first typed-up reply, so this may be lacking quality]. i deleted the script so i can't remember exactly what it was. basically, this is how it went:

alias test {
  echo -a $1-
  cmd $!test($1-)
alias cmd {
  noop $($1-,2)

alright, the previous code might work pretty decently. however, the problem came when i tried to call $test with a timer through command. if you were to call from within the test alias ".timer 1 10 cmd some crap $!test(craphere)" it would in theory work, however, the timer command itself 'knows' $! prefix for commands, and uses that to evaluate that at the time of the script. so if i do $!test($1-) inside of a timer, $1- will be null when the timer re-evals what $1- is. it was no big deal to just seperate aliases when i was writing the script or i would have tried $chr(whatever) $+ test and seen if that would work. either way, it was an annoyance at the time and explains how a lack of recursion just further causes problems with scripts that require recursion.