mIRC Home    About    Download    Register    News    Help

Print Thread
Joined: Sep 2004
Posts: 17
I
inhahe Offline OP
Pikka bird
OP Offline
Pikka bird
I
Joined: Sep 2004
Posts: 17
I'm trying to set up mIRC with ZNC, a popular IRC bouncer. So far I connect to Undernet and Libera. On Undernet it autojoins the channels it's supposed to, but it doesn't on Libera. I think it has no way of knowing that it's the Libera network it's connecting to. Maybe because when it connects it says welcome to Libera.Chat instead of Libera, or maybe it wouldn't know anyway, I don't know. I can't just add the address I'm connecting to Libera's servers list, because it's a bouncer so I'm connecting to the same address for all networks. Also my 'servers' section is missing from my preferences, so I can't edit servers in any way anyway, unless someone tells me how to fix that too.
Thanks for any help.

Joined: Jan 2004
Posts: 1,944
Hoopy frood
Offline
Hoopy frood
Joined: Jan 2004
Posts: 1,944
Sounds like you might need a lot of back/forth for your problem, might help to come to ##mirc on libera or efnet, or #mircscripting at swiftirc. if by 'preferences' you mean your Alt+E window doesn't have any servers, then something happened to servers.ini

Everyone just says libera, but the actual string for $network is Libera.Chat and it's unusual for networks to have a period in their $network string. Even mIRC itself needed an update back then to support the /server command using the groupname having a period instead of seeing it as a hostname

But yes, it helps greatly in mIRC for a variety if issues that you always connect to servers that are listed in your servers list, and even though it says the 'group' is optional, it's best that they match exactly what $network is there.


Link Copied to Clipboard