OK let's compare
Your suggestion. while (%inc = 1,%inc <= 10,inc %inc) code
My (and many thousands of others) suggestion. [color:red]for (%inc = 1,%inc <= 10,inc %inc) code[/color]
What's so terrible about it being called /for instead of hacking /while into something it's not? As for a custom command, it would be slow, awkward, and immensely limited.